Microsoft Excel

Herbers Excel/VBA-Archiv

ZÄHLENWENN.... | Herbers Excel-Forum


Betrifft: ZÄHLENWENN.... von: Josef
Geschrieben am: 01.02.2010 08:53:30

Hallo!

Ich würde bitte folgende Formel suchen:

In Spalte A steht z.B. 4 x 3171, 5 x 3172, 7 x 3173

In der Spalte N stehen Beträge und Zellen mit einer 0.

Ich möchte nun in Abhängigkeit der Spalte A die Anzahl der Zellen ermitteln, in denen Beträge stehen und keine 0.

Für eine lösung wäre ich dankbar.

Josef

  

Betrifft: AW: ZÄHLENWENN.... von: ede
Geschrieben am: 01.02.2010 08:58:45

guten morgen,
versuchs mal mit

=ZÄHLENWENN(A1:A9;"<>0")

für die Anzahl.

gruss


  

Betrifft: AW: ZÄHLENWENN.... von: Josef
Geschrieben am: 01.02.2010 09:06:20

Hallo ede!

Danke für Deine Antwort.

Mit der Formel =ZÄHLENWENN(A1:A9;"<>0") zähle ich nur in der Spalte A. Ich möchte jedoch in Abhängigkeit der Spalte A die Werte in der Spalte N zählen.

Josef



  

Betrifft: =SUMMENPRODUKT((A1:A99<>0)*(N1:N99<>0)) von: WF
Geschrieben am: 01.02.2010 09:15:48

Hi;

und bei
=ZÄHLENWENN(A1:A99;"<>0")
werden Leerzellen mitgezählt

bei
=SUMMENPRODUKT((A1:A99<>0)*1)
nicht

Salut WF


  

Betrifft: AW: =SUMMENPRODUKT((A1:A99<>0)*(N1:N99<>0)) von: Josef
Geschrieben am: 01.02.2010 09:33:29

Hallo!

Danke für Deine Antwort.
Mein Problem ist jedoch, dass ich nicht in der Spalte A zählen möchte, sondern in der spalte N in Abhängigkeit der Spalte A .

Josef


  

Betrifft: Betreff vs. Inhalt von: Renee
Geschrieben am: 01.02.2010 09:37:59

Hi Josef,

Versuch doch WF's Formel des Betreffs und nicht eine seiner Erklärung:

=SUMMENPRODUKT((A1:A99<>0)*(N1:N99<>0))
GreetZ Renée


  

Betrifft: AW: Betreff vs. Inhalt von: Josef
Geschrieben am: 01.02.2010 09:48:51

Hallo Renee!

Danke für Deine Antwort! Habe ich gleich danach gemacht, jedoch stimmt keine derc Summen.

Anbei eine Musterdatei:


https://www.herber.de/bbs/user/67670.xls

Josef


  

Betrifft: AW: Betreff vs. Inhalt von: Josef
Geschrieben am: 01.02.2010 10:00:23

Hallo!

Ich glaube, ich habe jetzt die Lösung.

Mit einer Hilfsspalte ginge es so:

=SUMMENPRODUKT(($E$272:$E$2434=S272)*($N$272:$N$2434<>0))

In S272 habe ich den Wert, welcher in E272:E2434 abgefragt wird.

Wenn jedoch in der Spalte N z.B. "KV" oder die Zelle leer ist, dann werden diese Werte auch mitgezählt, was jedoch nicht sein sollte.
Aber immerhin danke, bin jetzt einen Schritt weiter.

Josef


  

Betrifft: Musterdatei vs. Anfrage von: Renee
Geschrieben am: 01.02.2010 10:06:42

Hi Josef,

Struktur und Inhalt deiner Musterdatei haben nix mit deiner Anfrage und deinen Bemerkungen zu tun!
Ich finde weder eine Formel noch eine Hilfsspalte in der Datei.
Du setzt wohl voraus, dass wir deine Datei von unserer Position aus sehen können ?
Leider haben meine hellseherischen Fähigkeiten in den letzten Jahre stark nachgelassen !

Wo liegt das Problem ?? erloichte uns bitte... ;-)

GreetZ Renée


  

Betrifft: AW: Musterdatei vs. Anfrage von: Josef
Geschrieben am: 01.02.2010 10:30:12

Hallo Renee!

Danke für Deine Rückantwort. Die erste Musterdatei übermittelte ich, bevor ich die lösung hatte.

hier jetzt die Musterdatei mit den Formeln:

https://www.herber.de/bbs/user/67671.xls


Josef


  

Betrifft: Jetzt ist das Problem weg ;-) von: Renee
Geschrieben am: 01.02.2010 10:51:48

Hi Josef,

Irgendwie ist mir jetzt dein Problem abhanden gekommen.
Mit der Hilfsspalte hast du eine Lösung die funktioniert, oder nicht ?
Was genau suchst du denn ? Ohne Hilfsspalte oder was ?
Setzt du diese Formel:

=SUMMENPRODUKT(($A$1:$A$49=A1)*($N$1:$N$49<>0)

in der ganzen Spalte ein, werden bei jedem Eintrag das Resultat für den Wert von A angezeigt.
Willst du das Resultat nur einmal (z.B. beim ersten Auftreten eines Wertes von A) abhängig von A anzeigen, könntest du die Formel:
=(ZÄHLENWENN(A$1:A1;A1)=1)*(SUMMENPRODUKT(($A$1:$A$49=A1)*($N$1:$N$49<>0)))

in der ersten Zeile in einer Spalte einsetzen und runterkopieren. Damit wird ein Wert >0 (falls zutreffend) nur beim ersten Auftreten von N in Spalte A angezeigt.

GreetZ Renée


  

Betrifft: AW: Versuch mal ... von: dieter(drummer)
Geschrieben am: 01.02.2010 10:04:15

Hi Josef,

habe mal die Formel von Renee in z.B. F1 deiner Musterdatei gesetzt und die SPALTE C deiner Musterdatei in die Spalte N vorher kopiert (Du hattes in N nichts stehen! Kannst N also so auch nicht abfragen!).

Die Formel von Renne geht dann auch:

=SUMMENPRODUKT((A1:A99<>0)*(N1:N99<>0))
Will mich aber hier nicht weiter in die Spezialisten Rückmeldung weiter einklinken.

Gruß
Dieter(Drummer)