Zählenwenn?

Bild

Betrifft: Zählenwenn?
von: Born
Geschrieben am: 23.07.2015 08:59:25

Hallo Forum,
ich habe folgendes Problem:
In drei Spalten habe ich jeweils Zellen, in denen ein "x" vorkommen kann, oder sie sind leer. Es soll theoretisch pro Zeile immer nur eine Zelle mit einem "x" versehen sein. Als Plausi-Check bräuchte ich eine Formel, die mir zählt, wie oft mehr als 1 "x" pro Zeile vorkommt. Hat hier jemand eine Idee, wie man das am besten machen könnte? Mit Zählenwenn komme ich irgendwie nicht weiter...
Vielen Dank im voraus,
M. Born

Bild

Betrifft: AW: Zählenwenn?
von: SF
Geschrieben am: 23.07.2015 09:04:04
Hola,

=zählenwenn(A1:C1;"x")
dann hast du doch die Anzahl der X'e in den drei Spalten. Die Formel ziehst du dann runter.
Oder denke ich zu einfach?
Gruß,
steve1da

Bild

Betrifft: AW: Zählenwenn?
von: Born
Geschrieben am: 23.07.2015 09:09:22
Hallo Steve,
wenn in einer Zeile 2 "x" eingegeben werden, aber in der nächsten die Zellen leer bleiben, dann gleicht sich das wieder aus. Daher funktioniert das normale Zählewenn nicht. Ich bräuchte quasi ein Zählewenn pro Zeile und dann über alle Zeilen eine weitere Zählung, wenn die Zahl pro Zeile größer als 1 ist.
Viele Grüße,
M. Born

Bild

Betrifft: AW: Zählenwenn?
von: SF
Geschrieben am: 23.07.2015 09:12:02
Hola,
gibts noch mehr Sachen zu beachten? Was ist bei 3 X'n ein einer Zeile?
Ein konkretes Beispiel wäre toll.
Gruß,
steve1da

Bild

Betrifft: AW: Zählenwenn?
von: Born
Geschrieben am: 23.07.2015 09:17:40
Ja, es könnten auch 3x pro Zeile vorkommen.
0x: ist okay
1x: ist okay,
2x: nicht okay
3x: nicht okay
Beispiel:
Zeile 1: , , x
Zeile 2: x, x,
Zeile 3: , ,
Zeile 4: , x,
Zeile 5: x, ,
Zeile 6: , x, x
Als Ergebnis hätte ich gern in z.B. Zeile 7 das Ergebnis, dass 2 Fehler vorhanden sind, nämlich in Zeile 2 und 6. Wo genau die Fehler sind, ist nicht so wichtig, die Anzahl reicht aus.
Gruß,
M. Born

Bild

Betrifft: AW: Zählenwenn?
von: SF
Geschrieben am: 23.07.2015 09:27:55
Hola,
warum denn Zeile 2, ich dachte das wäre ok?

wenn in einer Zeile 2 "x" eingegeben werden, aber in der nächsten die Zellen leer bleiben, dann gleicht sich das wieder aus
Gruß,
steve1da

Bild

Betrifft: AW: Zählenwenn?
von: Born
Geschrieben am: 24.07.2015 11:21:50
Hallo Steve,
Zeile 2 ergibt einen Fehler, da dort 2 x vorkommen. Wenn ich nur einfach ein Zählewenn nutze, wird der Fehler durch Zeile 3 wieder ausgeglichen, so dass man den Fehler im Ergebnis nicht sieht. Die Formel von Werner ist aber genau das, was ich gesucht habe. Vielen Dank für Deine Mithilfe.
M. Born

Bild

Betrifft: mit z.B. SUMMENPRODUKT() und MMULT() ...
von: der neopa C
Geschrieben am: 23.07.2015 13:30:03
Hallo M. Born,
... so:


=SUMMENPRODUKT(N(MMULT(--(A1:C6="x");{1;1;1})>1))
Gruß Werner
.. , - ...

Bild

Betrifft: AW: mit z.B. SUMMENPRODUKT() und MMULT() ...
von: Born
Geschrieben am: 24.07.2015 11:23:01
Hallo Werner,
das war genau das, was ich gesucht habe.
Vielen Dank,
M. Born

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zählenwenn?"