Microsoft Excel

Herbers Excel/VBA-Archiv

Mehrere Übereinstimmung nebeneinander auflisten

Betrifft: Mehrere Übereinstimmung nebeneinander auflisten von: Matthias
Geschrieben am: 21.11.2014 07:50:48

Hallo zusamen

Ich habe eine folgende Zuständigkeitsliste:

A1 | B1 | C1
4 | Hans | HA
9 | Heidi | HE
A2 | Heidi | HE
F3 | Maria | MA
G9 | Maria | MA

Nun möchte ich gerne etwas weiter unten auflisten, für was wer zuständig ist, also das Ergebnis sollte so aussehen:

Hans (HA): 4
Heidi (HE): 9, A2
Maria (MA): F3, G9

Vielen vielen Dank jetzt schon für eure Hilfe und einen schönen Tag,
Matthias

  

Betrifft: mit Standardfunktion und Formeln ... von: neopa C (paneo)
Geschrieben am: 21.11.2014 08:27:57

Hallo Mathias,

... kopiere die Namen aus Spalte B nach unten in Spalte A (hier z.B. ab A21) dann nutze für die kopierten Namen die Funktion "Duplikate entfernen" aus dem Menü Daten.

Die Formel Aus B21 kopierst Du nach unten und die aus C21 nach unten und rechts. Wenn Du willst kannst Du ja diese Zellen alle aus Hilfszellen betrachten und die Werte jeder Ergebniszeile mittels der Funktion & verketten wenn Du es wirklich in einer Zelle zu stehen haben willst.

 ABCD
1A1B1C1 
24HansHA 
39HeidiHE 
4A2HeidiHE 
5F3MariaMA 
6G9MariaMA 
7    
8    
9    
10    
11    
12    
13    
14    
15    
16    
17    
18    
19    
20    
21Hans(HA)4 
22Heidi(HE)9A2
23Maria(MA)F3G9
24    

Formeln der Tabelle
ZelleFormel
B21="("&SVERWEIS(A21;B:C;2;)&")"
C21{=WENN(SPALTE(A1)>ZÄHLENWENN($B:$B;$A21); "";INDEX($A:$A;KKLEINSTE(WENN($B$1:$B$19=$A21;ZEILE(A$1:A$19)); SPALTE(A1))))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "Mehrere Übereinstimmung nebeneinander auflisten"