Bestimmte Zeilen aus Tabelle übertragen

Bild

Betrifft: Bestimmte Zeilen aus Tabelle übertragen
von: Montimontt
Geschrieben am: 07.05.2015 13:52:42

Hallo zusammen,
ich komme nicht auf die Lösung und hoffe auf Eure Hilfe!
https://www.herber.de/bbs/user/97513.xlsx
Wie der hochgeladenen Mappe zu entnehmen ist, sind in Tabelle1 verschiedene Raumdaten aufgelistet. Unsortiert.
Wenn in Tabelle2 in A1 ein Gebäudename eingetragen wird (siehe Beispiel), sollen in Tabelle3 autoamtisch alle Zeilen aus Tabelle1 aufgelistet werden, bei denen in Spalte A der Gebäudename aus Tabelle2 A1 eingetragen ist.
Freue mich über jede Antwort!
Montimontt

Bild

Betrifft: AW: Bestimmte Zeilen aus Tabelle übertragen
von: Daniel
Geschrieben am: 07.05.2015 14:04:49
Hi
folgende Formel in Tabelle3!A1 als Matrixformel eingeben:

=WENNFEHLER(INDEX(Tabelle1!A:A;KKLEINSTE(WENN(Tabelle1!$A$1:$A$99=Tabelle2!$A$1; ZEILE(Tabelle1!$A$1:$A$99));ZEILE($A1)));"") 
Eingabe immer mit STRG+SHIFT+ENTER abschließen
dann Formel nach rechts bis Spalte D ziehen und nach unten soweit wie benötigt.
"benötigt" heißt in diesem Fall, mindestens soweit nach unten, wie Gebäute in Tabelle1!A:A maxmial vor kommen kann.
Gruß Daniel

Bild

Betrifft: AW: Bestimmte Zeilen aus Tabelle übertragen
von: Montimontt
Geschrieben am: 07.05.2015 14:22:01
Perfekt, vielen lieben Dank!!!!

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Bestimmte Zeilen aus Tabelle übertragen"