Microsoft Excel

Herbers Excel/VBA-Archiv

wenn, oder im S-Verweis

Betrifft: wenn, oder im S-Verweis von: Frederic
Geschrieben am: 18.08.2004 10:35:26

Hallo Zusammen,

ich habe das Problem das meine Formel einfach zu lang wird. Ich muss mich auf verschiedene Kundennummern berufen bzw. die Werte (falls vorhanden) addieren.

Kann ich hier eine oder verknuepfung einbauen??

Danke & Gruesse

Frederic

=IF(ISNA(ROUND(VLOOKUP($AJ$2,'M:\2004\Accounting\Cash Control\CCSS & XBP\Vertragspartner\ICMP-Aktionmeeting\[Monatsabschluss 31.07.04.xls]ZDOP_ZS_GESAMT_200201'!$A$1:$AF$340,3,FALSE),-3)),0,ROUND(VLOOKUP($AJ$2,'M:\2004\Accounting\Cash Control\CCSS & XBP\Vertragspartner\ICMP-Aktionmeeting\[Monatsabschluss 31.07.04.xls]ZDOP_ZS_GESAMT_200201'!$A$1:$AF$340,3,FALSE),-3))+IF(ISNA(ROUND(VLOOKUP($AJ$3,'M:\2004\Accounting\Cash Control\CCSS & XBP\Vertragspartner\ICMP-Aktionmeeting\[Monatsabschluss 31.07.04.xls]ZDOP_ZS_GESAMT_200201'!$A$1:$AF$340,3,FALSE),-3)),0,ROUND(VLOOKUP($AJ$3,'M:\2004\Accounting\Cash Control\CCSS & XBP\Vertragspartner\ICMP-Aktionmeeting\[Monatsabschluss 31.07.04.xls]ZDOP_ZS_GESAMT_200201'!$A$1:$AF$340,3,FALSE),-3))ISNA(ROUND(VLOOKUP($AJ$4,'M:\2004\Accounting\Cash Control\CCSS & XBP\Vertragspartner\ICMP-Aktionmeeting\[Monatsabschluss 31.07.04.xls]ZDOP_ZS_GESAMT_200201'!$A$1:$AF$340,3,FALSE),-3))

  


Betrifft: AW: wenn, oder im S-Verweis von: Hans W. Herber
Geschrieben am: 18.08.2004 11:08:41

Hallo Frederic,

wegen solcher (Bombenleger-)Formeln sind schon Leute fristlos entlassen worden. Wenn Du mich fragst, mit recht ;-)

Du kannst die Formel natürlich in Einzelelemente aufteilen, was ganz bestimmt sinnvoll ist. Es kann auch nicht sehr problematisch sein, da Du ja addierst; die Elemente sind also relativ einfach zu trennen.

Alternativen:
- Eine benannte Formel (wird im Workshop meiner Excel-FAQ beschrieben), die auf jeden Fall die Sache im Tabellenblatt übersichtlicher macht.
- Über VBA Mappe öffnen, Werte eintragen, Mappe schließen. Ob das sinnvoll ist, hängt allerdings noch von anderen Gegebenheiten ab.

Gruss hans


  


Betrifft: Und du glaubst wirklich... von: Boris
Geschrieben am: 18.08.2004 11:10:02

Hi Frederic,

dass sich jemand mit diesem Ungetüm auseinandersetzt?

Worin besteht das eigentlich Problem?
Lass doch mal die Pfade aus deiner Beispielformel raus - z.B.

'M:\2004\Accounting\Cash Control\CCSS & XBP\Vertragspartner\ICMP-Aktionmeeting\[Monatsabschluss 31.07.04.xls]ZDOP_ZS_GESAMT_200201'

Dann wird das Ganze auch direkt mal übersichtlicher...

Grüße Boris


  


Betrifft: AW: Und du glaubst wirklich... von: Frederic
Geschrieben am: 18.08.2004 13:35:01

Hallo Boris,

stimmt es ist alles unuebersichtlich. Das eigentliche Problem ist das ich 5 Bezugsfelder habe z.b. a1, a2, a3, a4,a5 die alle mit dem S-Verweis daten aus anderen Tabellen ziehen. Diese Daten sollen anschliessend addiert werden.

Kann ich das z. B. so darstellen oder so aehnlich mit einer "oder" formel darstellen.

IF(ISNA(ROUND(VLOOKUP(a1, a2, a3, a4,a5,quelle,3,FALSE),-3)),0,ROUND(VLOOKUP($AJ$2,quelle,3,FALSE),-3))


muss sagen das ich mich noch nicht wirklich mit excel foren beschaeftigt habe und mich deshalb evtl. undeutlich ausdrueck...:-)


  


Betrifft: Das ist ein Fall für SUMMEWENN von: Boris
Geschrieben am: 18.08.2004 14:57:46

Hi Frederic,

am ganz einfachen Beispiel:

In A1 bis A5 stehen deine 5 Suchbegriffe.
Deine Suchmatrix ist E:F - die zu summierenden Zahlen also in F.

Dazu diese Formel:
=SUMMENPRODUKT(SUMMEWENN(E:E;A1:A5;F:F))

Kommst du damit klar?

Grüße Boris


  


Betrifft: AW: Das ist ein Fall für SUMMEWENN von: Frank
Geschrieben am: 18.08.2004 15:36:53

Hi
grundsätzlich stimme ich Boris formel ja zu, ich befürchte aber, wenn ich Dein Formelmonster sehe, das Deine referenzierte Datei geschlossen ist. Wenn nein, wende Boris Formel an. Wenn Sie aber geschlossen sein sollte, wird SUMMEWENN nicht funktionieren. probiere dann mal folgende Alternative aus:

=SUMMENPRODUKT(--(ISTZAHL(VERGLEICH('M:\2004\Accounting\Cash Control\CCSS & XBP\Vertragspartner\ICMP-Aktionmeeting\[Monatsabschluss 31.07.04.xls]ZDOP_ZS_GESAMT_200201'!$A$1:$A$340;$AJ$2:$AJ$4;0)));'M:\2004\Accounting\Cash Control\CCSS & XBP\Vertragspartner\ICMP-Aktionmeeting\[Monatsabschluss 31.07.04.xls]ZDOP_ZS_GESAMT_200201'!$C$1:$C$340))

Summiert die Spalte C in Deiner Datei auf, wenn spalte A mit den Werten AJ2:AJ4 übereinstimmt

Frank





'M:\2004\Accounting\Cash Control\CCSS & XBP\Vertragspartner\ICMP-Aktionmeeting\[Monatsabschluss 31.07.04.xls]ZDOP_ZS_GESAMT_200201'!$A$1:$AF$340