Microsoft Excel

Herbers Excel/VBA-Archiv

Daten in eine Spalte

Betrifft: Daten in eine Spalte von: Thomas
Geschrieben am: 31.08.2004 07:54:26

Hallo Profis,

Die Formel die ich suche ist wahrscheinlich ziemlich einfach, aber ich komm einfach nicht drauf.

Ich habe 4 tabellenblätter, in 2 3 und 4 können in B17 bis B20 Daten stehen.
im ersten Tabellenblatt sollen die´se Daten nun übernommen werden. Wenn dort auch welche stehen. das Problem ist nur, dass keine Leerzeilen zwische den daten erscheinen sollen.

Denn in den Tabellen können mal nur 1 Wert, oder 2 oder 3 Werte stehen.
Wie kriege ich nun diese unbestimmte Zahl von Werten untereinander in Tabellenblatt 1.

Schon mal Danke im Voraus.

Gruß Thomas

  


Betrifft: AW: Daten in eine Spalte von: Günther Oppold
Geschrieben am: 31.08.2004 12:28:51

Hallo Thomas

hier mein Lösungsvorschlag

Anmerkung: Die Formel in Tabelle3 C3
1.) ist eine ARRAY-Formel: die geschweifte Klammer nicht eingeben, sondern die Formeleingabe abschließen mit Strg+Umsch+Enter
2.) der String in Kkleinste(...;Zeile()-2) hier muss die Berechnung in deiner ersten Auswertung eine 1 ergeben. fängst Du also in Zeile 10 mit der Zusammenfassung an, so muss die Formel auf kkleinste(...;Zeile()-9) abgeändert werden.
Die Spalte A im Tabellenblatt 3 ist eine Hilfsspalte und kann ausgeblendet werden

Tabelle1
 B
171
182
19 
204
 
Tabelle2
 B
1710
18 
1912
2013
 
Tabelle3
 ABC
11 Zusammenfassung:
22  
3  1
44 2
510 4
6  10
712 12
813 13
9   
Formeln der Tabelle
A1 : =WENN(Tabelle1!B17="";"";Tabelle1!B17)
A2 : =WENN(Tabelle1!B18="";"";Tabelle1!B18)
A3 : =WENN(Tabelle1!B19="";"";Tabelle1!B19)
C3 : {=WENN(ISTFEHLER(INDEX(A$1:A$1000;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE()-2)));"";INDEX(A$1:A$1000;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE()-2)))}
A4 : =WENN(Tabelle1!B20="";"";Tabelle1!B20)
C4 : {=WENN(ISTFEHLER(INDEX(A$1:A$1000;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE()-2)));"";INDEX(A$1:A$1000;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE()-2)))}
A5 : =WENN(Tabelle2!B17="";"";Tabelle2!B17)
C5 : {=WENN(ISTFEHLER(INDEX(A$1:A$1000;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE()-2)));"";INDEX(A$1:A$1000;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE()-2)))}
A6 : =WENN(Tabelle2!B18="";"";Tabelle2!B18)
C6 : {=WENN(ISTFEHLER(INDEX(A$1:A$1000;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE()-2)));"";INDEX(A$1:A$1000;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE()-2)))}
A7 : =WENN(Tabelle2!B19="";"";Tabelle2!B19)
C7 : {=WENN(ISTFEHLER(INDEX(A$1:A$1000;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE()-2)));"";INDEX(A$1:A$1000;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE()-2)))}
A8 : =WENN(Tabelle2!B20="";"";Tabelle2!B20)
C8 : {=WENN(ISTFEHLER(INDEX(A$1:A$1000;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE()-2)));"";INDEX(A$1:A$1000;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE()-2)))}
C9 : {=WENN(ISTFEHLER(INDEX(A$1:A$1000;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE()-2)));"";INDEX(A$1:A$1000;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE()-2)))}
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Günther

 

Beiträge aus den Excel-Beispielen zum Thema "Daten in eine Spalte "