Microsoft Excel

Herbers Excel/VBA-Archiv

summe(wenn( - "zuviele Argumente?"

    Betrifft: summe(wenn( - "zuviele Argumente?" von: Hansi
    Geschrieben am: 02.09.2003 09:02:01

    Guten Morgen,
    um von Bereichen auf ganze Spalten überwechseln zu können,
    möchte ich die erste Formel auf "Summe(wenn(" umstellen,
    damit ich im zweiten Gang ganze Spalten wie etwa "B:B"
    festlegen kann. Die zweite Formel funktioniert nicht.
    Als Meldung erscheint "Zuviele Argumente..."
    Selbst wenn ich mehr als eine der letzten Klammern weglasse,
    erscheint immer noch dasselbe.

    =SUMMENPRODUKT((MONAT(Formular!$B$9:$B$5000)=F$2)*
    (JAHR(Formular!$B$9:$B$5000)=$C$2)*
    ((Formular!$H$9:$H$5000)=$A7)*
    (Formular!$I$9:$I$5000))

    =SUMME(wenn((MONAT(Formular!$B:$B=F$2;
    wenn(JAHR(Formular!$B:$B=$C$2;
    wenn(Formular!$H:$H=$A7;
    Formular!$I:$I)))))))}

    Kann mir jemand helfen?
    Vielen Dank im Voraus.

    Gruss von Hansi

      


    Betrifft: AW: summe(wenn( - "zuviele Argumente?" von: Hansi
    Geschrieben am: 02.09.2003 09:39:02

    Bin mittlerweile weitergekommen,

    {=SUMME(WENN(MONAT(Formular!B:B)=F$2;
    WENN(JAHR(Formular!B:B=$C$2);
    WENN(Formular!H:H=$A7;
    (Formular!I:I)))))}

    Mit dieser Formel erhalte ich aber die
    Fehlermeldung "#Zahl".

    Was ist daran falsch?
    Vielen Dank
    Hansi


      


    Betrifft: Mit SUMME(WENN(... kannst du nicht B:B ... von: Boris
    Geschrieben am: 02.09.2003 09:47:31

    Hi Hansi,

    ...referenzieren, denn es bleibt eine Array-Formel - und die kann nunmal nicht mit ganzen Spalten.

    In Deiner SUMMENPRODUKT-Formel sind die Klammern auch falsch gesetzt - daher erhälst du sicherlich die Fehlermeldung.

    Grüße Boris


      


    Betrifft: AW: Mit SUMME(WENN(... kannst du nicht B:B ... von: Hansi
    Geschrieben am: 02.09.2003 10:16:58

    Hallo Boris,

    Summenprodukt funktionierte zwar, aber vielleicht ist
    die Formel hier falsch abgeschrieben worden.

    Trotzdem - welche Möglichkeit gäbe es, in diesem Falle
    mit ganzen Spalten arbeiten zu können?
    Ich denke, wenn man in vielen Spalten große Bereiche
    festlegt, leidet auch die Rechnergeschwindigkeit darunter,
    zumindest konnte ich dies in erheblichem Umfange feststellen.

    Vielen Dank auch für deine Nachricht von vorhin.
    Gruss Hansi


      


    Betrifft: Bei großen Bereichen sind Hilfsspaltenlösungen... von: Boris
    Geschrieben am: 02.09.2003 10:25:24

    Hi Hansi,

    ...zu bevorzugen.

    Um z.B. zu zählen, wie oft in Spalte A bis E in jeder Zeile ein A steht, kann man schreiben:
    =SUMMENPRODUKT((A1:A10000="A")*(B1:B10000="A")*(C1:C10000="A")*(D1:D10000="A")*(E1:E10000="A"))

    Schneller geht es mit einer Hilfsspalte:
    In F1: =A1&B1&C1&D1&E1
    und runterkopieren bis F10000.
    Dann die Anzahl:
    =ZÄHLENWENN(F:F;"AAAAA")

    Ist wesentlich flotter - und du kannst ganze Spalten referenzieren (auch mit SUMMEWENN).

    Grüße Boris


     

    Beiträge aus den Excel-Beispielen zum Thema " summe(wenn( - "zuviele Argumente?""