Microsoft Excel

Herbers Excel/VBA-Archiv

nochmal wenn dann

Betrifft: nochmal wenn dann von: Marcel
Geschrieben am: 08.09.2004 14:05:52

servus excel götter :)

hatte eben schon mal nach einer wenn dann formel gefragt. bekomms aber nit hingeschustert.

ich brauche eine wenn dann formel die folgendes macht:

wenn a1 < 5 dann a2*9
wenn a1 zwischen 5,01 und 10 dann a2*12
wenn a1 zwischen 10,01 und 15 dann a2*15
wenn a1 > 15,01 dann a2*18

geht das?

danke
gruß
marcel

  


Betrifft: AW: nochmal wenn dann von: JRobert
Geschrieben am: 08.09.2004 14:14:59

Hallo Marsel,

=WENN(A1<5,01;A2*9;WENN(A1<10,01;A2*12;WENN(A1<15,01;A2*15;A2*18)))

gruß Robert


  


Betrifft: AW: nochmal wenn dann von: HeinzS
Geschrieben am: 08.09.2004 14:20:09

Versuchs mal damit:
=IF(B1<>0,IF(B1<=5,B2*9, IF(AND(B1>5,B1<=10),B2*12, IF(AND(B1>10,B1<=15),B2*15, IF(B1>15,B2*18)))),0)

Lg,Heinz


  


Betrifft: AW: nochmal wenn dann von: Daniel
Geschrieben am: 08.09.2004 14:23:03

Hi,
bei dir sind die 5, die 10 und die 15 nicht klar definiert, müsste aber so aussehen:

=WENN(A1<=5;A2*9;WENN(UND(A1>5;A1<=10);A2*12;WENN(UND(A1>10;A1<15);A2*15;WENN(A1>=15;A2*18))))

mfg Daniel


  


Betrifft: danke es geht! von: Marcel
Geschrieben am: 08.09.2004 14:45:47

funst super!
danke!


  


Betrifft: AW: nochmal wenn dann von: Dieter.K
Geschrieben am: 08.09.2004 14:54:57

Hallo Praktikant,

vielleicht so?


=WENN(A1<5,01;A2*9;WENN(UND(A1>5;A1<10,01);A2*12;WENN(UND(A1>10;A1<15,01);A2*15;WENN(A1>15;A2*18;0))))



In Deiner Frage würde bei exact 5 das Ergebnis 0 sein.


Gruß
Dieter.K


  


Betrifft: es geht es geht von: Marcel
Geschrieben am: 08.09.2004 15:16:54

danke papa :)