Herbers Excel-Forum - das Archiv

Prozentanzahl berechnen lassen?



Excel-Version: 97
nach unten

Betrifft: Prozentanzahl berechnen lassen?
von: Thomas


Geschrieben am: 08.05.2002 - 13:55:48

Ich habe 2 Spalten (z.B. Spalte B und Spalte C)

In der Spalte B stehen die Schritte, die erledigt werden müssen für ein bestimmtes Projekt. (normaler Text)

In der Spalte C steht 0 oder 1. 0 bedeutet noch nicht erledigt, 1 erledigt.

Nun würde ich gerne in die Zelle A1 den Prozentwert der noch nicht erledigten Aufgaben automatisch reinschreiben lassen. Dieser Wert beginnt also am Anfang des Projekts mit 100% und ist am Ende des Projekts 0%.

Also #0 in der Spalte C/# der nichtleeren Zellen in der Spalte B

Ich habe =DBANZAHL2(C1:CB5338;C1;0) zum Zählen der Nullen ausprobiert, hat aber nicht geklappt.

Kann jemand helfen? Bedanke mich schon im Voraus.

nach oben   nach unten

Re: Prozentanzahl berechnen lassen?
von: Michael Wendeler

Geschrieben am: 08.05.2002 - 14:12:29

Hallo,

nimm folgende Formel:

=ZÄHLENWENN(C1:C5338;0)/ANZAHL(C1:C5338)

und die Zelle als Prozentzahl formatieren.

Gruß
M. Wendeler
http://www.wendelers.de

nach oben   nach unten

DANKE Michael !
von: Thomas

Geschrieben am: 08.05.2002 - 14:39:11

Habe am Schluss =ZÄHLENWENN(C5:C5339;0,1)/ANZAHL(C5:C5339) genommen. 0 zu verwenden scheint Probleme zu bereiten, da hab ich halt 0,1 genommen. ;)
nach oben   nach unten

Re: DANKE Michael !
von: Michael Wendeler

Geschrieben am: 08.05.2002 - 14:42:44

Zur Not kannst Du auch folgende Formel nehmen wenn es mit der 0 nicht klappt.

=(Anzahl(C5:C5339)-ZÄHLENWENN(C5:C5339;1))/ANZAHL(C5:C5339)

Gruß
M. Wendeler
http://www.wendelers.de

nach oben   nach unten

Re: DANKE Michael !
von: Thomas
Geschrieben am: 08.05.2002 - 14:52:20

Ja, funktioniert perfekt! Danke nochmal!

nach oben   nach unten

Noch eine Frage
von: Thomas

Geschrieben am: 08.05.2002 - 14:59:24

Die Formel kann man aber nur für einen fixen Bereich verwenden. Ich würde dies aber gerne dynamisch machen. d.h. die Anzahl der Nullen und die Anzahl der Einsen sollte berücksichtigt werden.
Anzahl 0 / Anzahl 1 + Anzahl 0

nach oben   nach unten

Re: Noch eine Frage
von: Michael Wendeler


Geschrieben am: 08.05.2002 - 15:08:27

Ich weiß nicht, ob ich die Frage richtig verstanden habe, aber in der Formel werden mit Anzahl nur die Zellen gezählt, in denen sich eine Zahl befindet.

D.H. wenn du Anzahl(C5:C5339) hast und nur in dem Bereich C5:C124 stehen Zahlen, dann werden auch nur diese gezählt.

Gruß
M. Wendeler
http://www.wendelers.de

nach oben   nach unten

Danke
von: Thomas

Geschrieben am: 08.05.2002 - 15:20:20

Eigentlich liegt mein Problem wegen der 0,1 statt 0 wo anders, ich benutze nämlich bedingte Formatierung um sie besser sichtbar zu machen, und leere Felder und Felder mit 0 werden da nicht unterschieden.

nach oben   nach unten

Re: Danke
von: Michael Wendeler


Geschrieben am: 08.05.2002 - 15:29:31

Gib mal in die bedingte Formatierung folgendes ein:

Formel ist =UND(A1=0;A1<>"")

Dann wird die Zelle A1 nur dann formatiert, wenn sie gleich 0 ist und nicht, wenn sie leer ist.

Gruß
M. Wendeler
http://www.wendelers.de

nach oben   nach unten

Re: Danke
von: Thomas
Geschrieben am: 08.05.2002 - 15:46:19

Und wie kann ich das für eine Spalte machen, anstatt für nur A1?

nach oben   nach unten

Re: Danke
von: Michael Wendeler
Geschrieben am: 08.05.2002 - 20:32:55

Einfach mit Hilfe des "Pinsels" aus der Symbolleiste das Format herunter kopieren.

 nach oben

Excel-Beispiele zum Thema "Prozentanzahl berechnen lassen?"
Quersumme berechnen Arbeitsmappe alle 5 Minuten neu berechnen
Wert aus 2. UserForm-ComboBox-Spalte berechnen Aktuelle Zeit über UserForm eintragen und Rennzeit berechnen
Verbleibende Nettoarbeitstage des Monats berechnen Modalwert einer gefilterten Reihe berechnen
Werte aus Zeichenfolgen filtern und berechnen Zuschläge gem. Tabelle berechnen
TextBox-Eingabe mit Formel weiterberechnen und zurückgeben Eine WENN-Formel nur bei der ersten Werteänderung berechnen