Microsoft Excel

Herbers Excel/VBA-Archiv

Blattschutz führt zu Abbruch !

Betrifft: Blattschutz führt zu Abbruch ! von: wulfjack
Geschrieben am: 18.08.2008 10:49:05

... das hatte ich noch nie, obwohl ich sicherlich schon viel komplexere Excel-Dateien erstellt habe!
In einer Exceldatei mit 3 Arbeitsblättern ist das erste Arbeitsblatt als "Eingabe" definiert, d.h. von den benutzten Spalten A-N und den Zeilen 1 - 2000, ist nur der Bereich B10-B2000 "ungesperrt". Alle anderen Zellen sind "gesperrt" und ausgeblendet, da sich dahinter ausnahmslos Formeln befinden, die der Anwender erstens nicht sehen soll/muss, aber auch nicht löschen soll.
Teilweise werden die darin befindlichen Daten auch von einem anderen Arbeitsblatt befüllt ( z.B. =DATEN!A10 ) oder auch mit SVERWEIS z.B. =SVERWEIS(A10;DATEN!$C$10:$E$200;3;FALSCH)

Also, alles in allem kein Hexenwerk!

Aber jetzt kommt's! Sobald ich das Blatt schütze und somit eigentlich nur noch B10-B2000 bearbeiten kann, hängt sich Excel bei der ersten Eingabe in B komplett auf, d.h. die "Eieruhr" läuft, der Taskmanager meldet 100% und nach ein paar Minuten "keine Rückmeldung" von der Anwendung.

Dann hilft nur noch Prozess abbrechen..... !

Ich bin ratlos..... HILFE !

  

Betrifft: doppelt von: doppelt
Geschrieben am: 18.08.2008 11:04:58




 

Beiträge aus den Excel-Beispielen zum Thema "Blattschutz führt zu Abbruch !"