Zeileninhalte nach Kriterien suchen

Bild

Betrifft: Zeileninhalte nach Kriterien suchen
von: Zwilland
Geschrieben am: 27.04.2015 09:51:05

Hallo zusammen, für ein Inventory suche ich eine Formel die mir Zeileninhalte nach bestimmten Kirterien in einer Spalte sucht:
Ich möchte in der Zelle B1 Auszüge von Zeichenfolgen der Zeile anzeigen lassen, die in Spalte A mit folgenden Inhalt vorkommt: "Megabytes Usable Installed Memory"
Und zwar Konkret die Zeichenfolge 32 bis 45 von rechts nach links gelesen.

Bild

Betrifft: AW: Zeileninhalte nach Kriterien suchen
von: ransi
Geschrieben am: 27.04.2015 10:07:46
Hallo,
"Megabytes Usable Installed Memory"
Und zwar Konkret die Zeichenfolge 32 bis 45 von rechts nach links gelesen.

Das versteh ich nicht.
Was soll bei deinem Beispielstring ausgegeben werden ?
ransi

Bild

Betrifft: AW: Zeileninhalte nach Kriterien suchen
von: Zwilland
Geschrieben am: 27.04.2015 11:31:38
Hallo,
es soll nur der Wert ausgegeben werden. z.B: 16308 M
16308 Megabytes Usable Installed Memory
in dem Fall wäre das der Wert der zwischen der Zeichenstelle 32-39 liegt. Wenn ich also von Links gezählt 32 bis 45 angebe, bekomme ich immer den Zahlenwert mit der Angabe "M" für Memory. Die Zeichenfolge links "Megabytes Usable Installed Memory" ist im unterschied zu der Spezifikationsbezeichnung die vor der Memory-Größenangabe steht immer gleich(lang)
Grüße A.

Bild

Betrifft: =WERT(LINKS(A1;FINDEN(" ";A1))) (owT)
von: EtoPHG
Geschrieben am: 27.04.2015 11:35:05


Bild

Betrifft: AW: =WERT(LINKS(A1;FINDEN(" ";A1))) (owT)
von: Zwilland
Geschrieben am: 29.04.2015 15:21:08
Hallo EtoPHG, leider bin ich mit deinem Beispiel nicht zurechtgekommen, weil ich es nicht verstanden habe:
=WERT(LINKS(A1;FINDEN(" ";A1)))
Trotzdem vielen Dank, vielleicht kapier ich ja noch deine Lösung
Jetzt habe ich mich etwas eingelesen mit der Funktion: "VERGLEICH" und bin da etwas vorwärts gekommen.
Ich kann jetzt mit der Funktion aus der Zelle C8, in der der Wert "Megabytes Usable Installed Memory" steht,die Zeilennummer anzeigen lassen:
=VERGLEICH("*"&C8&"*";A1:A900;0)
Das hilft mir schon mal weiter. Jetzt kenne ich also die Zeilennummer, die z.B. in Zelle F8 angezeigt wird. Die Spaltennummer 1 ist auch bekannt, da ja nur in der Spalte A also 1 gesucht wird.
Wie würde jetzt der Aufruf aussehen, wenn ich in Zelle D8 den Bezug auf die Zeilennummer von F8 und der Spalte 1 zusammensetzen möchte. In dem Beispiel ist es die Zeilennummer 18
Liebe Grüße Andy


Bild

Betrifft: AW: =WERT(LINKS(A1;FINDEN(" ";A1))) (owT)
von: EtoPHG
Geschrieben am: 29.04.2015 17:57:54
Hallo Andy,
Deine Ursprungsanfrage war etwas gar rudimentär formuliert. Aber wenigstens hast du dir die Mühe gegeben selbst daran weiterzuarbeiten und kommst der Sache näher.
Z.B. so:

=WERT(LINKS(INDEX(A1:A900;D8);FINDEN(" ";INDEX(A1:A900;D8))))

Gruess Hansueli

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zeileninhalte nach Kriterien suchen"