Microsoft Excel

Herbers Excel/VBA-Archiv

doppelte Werte suchen und markieren | Herbers Excel-Forum


Betrifft: doppelte Werte suchen und markieren von: Wolfgang
Geschrieben am: 26.11.2009 12:32:37

Hallo,
suche eine Lösung für folgendes Problem:
Habe eine Tabelle, in der von Zelle A10 bis J1000 Daten mittels Maske eingetragen werden. Nun kommt es vor, das bei der Auswertung = Ausdruck in einigen Zeilen (immer die komplette Zeile ist doppelt, nicht eine Zelle !!!) doppelte Werte stehen.
Gibt es eine Möglichkeit per Makro, den Bereich von A10:J1000 zeilenweise nach doppelten Einträgen, die in allen Spalten vorkommen müssen, zu suchen und diese evtl. per bedingte Formatierung farblich zu markieren. Versuche es schon mittels Makroaufzeichnung, aber es klappt irgendwie nicht ;-(

vielen Dank für mögliche Hilfe
Wolfgang

  

Betrifft: AW: doppelte Werte suchen und markieren von: Rudi Maintaire
Geschrieben am: 26.11.2009 12:43:01

Hallo,
in einer Hilfsspalte die Zellen A:J verketten und mit Zählenwenn auf Duplikate testen.

Gruß
Rudi


  

Betrifft: AW: doppelte Werte suchen und markieren von: Wolfgang
Geschrieben am: 26.11.2009 13:00:15

Hallo,

das hatte ich auch schon mal irgendwie probiert und hat nicht funktioniert, aber ich meine das so, dass es keine "Vorgabe" über eine Maske oder so gibt, einfach nur nach möglichen doppelten oder mehrfach vorkommenden gleichen Zellen EINER Zeile markieren? Vielleicht habe ich mich auch falsch ausgedrückt ;-(
Wolfgang


  

Betrifft: AW: doppelte Werte suchen und markieren von: Mike
Geschrieben am: 26.11.2009 13:11:35


Hey Wolfgang,

das Zählenwenn ist keine Maske und lässt sich
auch gut auf Deine Zeilen-Anforderung anwenden.


Tabelle1

 ABCDEFGHIJ
25  112121345
26  344556111

verwendete Formeln
Zelle Formel
B26 =ZÄHLENWENN($B2:B25; B25)
C26 =ZÄHLENWENN($B2:C25; C25)
D26 =ZÄHLENWENN($B2:D25; D25)
E26 =ZÄHLENWENN($B2:E25; E25)
F26 =ZÄHLENWENN($B2:F25; F25)
G26 =ZÄHLENWENN($B2:G25; G25)
H26 =ZÄHLENWENN($B2:H25; H25)
I26 =ZÄHLENWENN($B2:I25; I25)
J26 =ZÄHLENWENN($B2:J25; J25)

Füllfarben und Muster
Zelle Rot Grün Blau Color Muster Farbe
A25 19219219212632256   
Zellen mit Füllfarbe automatisch werden nicht dargestellt

Tabellendarstellung in Foren Version 4.28




Gruss
Mike


  

Betrifft: AW: doppelte Werte suchen und markieren von: Wolfgang
Geschrieben am: 26.11.2009 13:31:11

Hallo Mike,

dass "zählenwenn" keine Maske ist, das ist schon klar!

Es ist einfach so gesagt oder geschrieben:

(Makro) gucke mal nach, ob im Bereich a10:j1000 und NUR da ZEILENWEISE irgendwo sich auf der kompletten Zeile a:j etwas doppelt befindet?







und dann markiere es















Ich weiß es hört sich kompliziert an, aber ich gebe mir mühe, es einfach zu erklären ;-)


  

Betrifft: AW: doppelte Werte suchen und markieren von: hary
Geschrieben am: 26.11.2009 14:09:13

Hallo Wolfgang
Versuch. meinst Du so? ohne makro
https://www.herber.de/bbs/user/66197.xls
gruss Hary


  

Betrifft: AW: doppelte Werte suchen und markieren von: Wolfgang
Geschrieben am: 26.11.2009 14:15:48

Hallo Hary,

nein!
als beispiel genannnt:

in der zeile a100 sind die werte folgend vorhanden:
a100= 1; b100=abx; c100=klm; d100=123; e100=abs; f100=abt; g100=0987; h100=4568 und j100=xxx

und diese zeile kommt irgendwann mal so in Zeile 600 nochmals vor!

Nun würde ich eben gerne diese Zeile als Wiederholung von Zeile 100 markiert haben und zwar die gesamte Zeile!!

Vielleicht hilft dies ...

Gruß
Wolfgang


  

Betrifft: AW: doppelte Werte suchen und markieren von: hary
Geschrieben am: 26.11.2009 14:39:18

Hi Wolfgang
dann versuch mal dies, mit Hilfspalte(wenn machbar).
https://www.herber.de/bbs/user/66198.xls
gruss hary


  

Betrifft: AW: doppelte Werte suchen und markieren von: Wolfgang
Geschrieben am: 26.11.2009 15:19:27

Danke,

das isses!! vielen vielen Dank!

Wolfgang


  

Betrifft: Bitte, danke fuer Rueckmeldung owT von: hary
Geschrieben am: 26.11.2009 15:21:46

.


  

Betrifft: AW: Bitte, danke fuer Rueckmeldung owT von: Wolfgang
Geschrieben am: 26.11.2009 15:43:59

äääh, habe das makro nun in die datei von mir übernommen und nun stürzt excel immer ab!
Jetzt bin ich ratlos?
Habe in der Datei von Dir das ein paarmal durchprobiert und auch nach unten entsprechende kopiert und da hat es mit den Buchstaben geklappt, aber nun nicht mehr ?

Woran kann das wieder liegen?

Gruß
Wolfgang


  

Betrifft: AW: Bitte, danke fuer Rueckmeldung owT von: Wolfgang
Geschrieben am: 26.11.2009 15:52:37

Hallo Hary,

weiß auch schon woran es liegt,

da unterhalb von der Zeile z.B. 222 nichts mehr steht möchte nun das Makro alle Zeilen markieren und nun hat der PC ein Problem und bringt eben Excel zum Absturz!!

weiß nicht wie man dies "auffangen" kann oder dass der Bereich zum Überprüfen erst "abgefragt" wird ob Zellen 'benutzt' also beschrieben sind und den Rest einfach nicht mit "kontrolliert" oder so ...
... vielleicht habe ich mich auch ein bißchen dumm ausgeschrieben ;-)

Gruß
Wolfgang


  

Betrifft: AW: teste mal von: hary
Geschrieben am: 26.11.2009 16:21:57

hallo
dann versuch's mal so. von zeile 10 bis letzte benutzte Zelle in SpalteA

Dim i As Long
Dim rng As Range
Application.ScreenUpdating = False
Range("A10:J1000").Interior.ColorIndex = xlNone
For i = 10 To Cells(Rows.Count, 1).End(xlUp).Row ' 1 bis letzte benutzte zeile in SpalteA
 If WorksheetFunction.CountIf(Range("K10:K1000"), Cells(i, 11)) > 1 Then
 For Each rng In Range("A" & i & ":J" & i)
 rng.Interior.ColorIndex = 3
 Next
 End If
 Next
 Application.ScreenUpdating = True

gruss hary


  

Betrifft: AW:beispielmappe von: hary
Geschrieben am: 26.11.2009 16:02:14

Hallo Wolfgang
lad mal eine beispielmappe hoch wo's zum Absturz kommt.
gruss hary


  

Betrifft: AW: AW:beispielmappe von: Wolfgang
Geschrieben am: 26.11.2009 16:20:10

wie ?
was ist damit gemeint?

bin ja nicht der profi und weiß nicht was damit gemeint ist


  

Betrifft: AW: besser so!!! von: hary
Geschrieben am: 26.11.2009 16:28:46

hallo Wolfgang
so ist es besser. Es werden nur die gefuellten Zeilen geprueft.
hier die Mappe.
https://www.herber.de/bbs/user/66204.xls

Dim i As Long
Dim rng As Range
Application.ScreenUpdating = False
Range("A10:J1000").Interior.ColorIndex = xlNone
For i = 10 To Cells(Rows.Count, 1).End(xlUp).Row ' 1 bis letzte benutzte zeile in SpalteA
 If Cells(i, 1) <> "" Then
 If WorksheetFunction.CountIf(Range("K10:K1000"), Cells(i, 11)) > 1 Then
 For Each rng In Range("A" & i & ":J" & i)
 rng.Interior.ColorIndex = 3
 Next
 End If
 End If
 Next
 Application.ScreenUpdating = True

gruss hary


Beiträge aus den Excel-Beispielen zum Thema "doppelte Werte suchen und markieren"