Microsoft Excel

Herbers Excel/VBA-Archiv

Suche bei vorangestellter Null

Betrifft: Suche bei vorangestellter Null von: Roman M
Geschrieben am: 26.03.2020 11:19:43

Hallo ihr,

ich habe eine Matrix mit zweistelligen Zahlen, welche die PLZ-Gebiete (die ersten 2 Zahlen einer PLZ) in Deutschland darstellen sollen gemäß der Aufteilung einer Versandkostenliste einer Spedition. Dabei sind die zusammengehörigen PLZ-Gebiete in einzelnen Zellen innerhalb einer Zeile aufgeführt. In der ersten Spalte ist einfach eine Nummer aufgefürt, weil mit dieser Zahl dann weiterrechnen will. Es ist aber quasi einfach die Zeilennummer in der das PLZ-Gebiet steht.

  • 1 01 02 03

    2 04 09

    3 06 07 08 14 15

    4 10 11 12 13 16 39 95

    5 18 19 29 30 31 34 36 37

    6 17 20 21 22 23 28 32 33

    7 24 25 26 27 46 47 48 49

    8 54 66 77 78 79 87 88


  • Jetzt soll halt in ein Feld die PLZ eingegeben und dann die richtige Zeilennummer zu dieser raus gesucht werden. Die Formel hierzu lautet:
    =SUMMENPRODUKT(($A$1:$AE$8=WERT(LINKS(I12;2)))*ZEILE($A$1:$A$8))

    Es funktioniert auch super, aber sobald man eine PLZ hat mit 0 am Anfang findet er nicht die richtige Zeile. Was er dann ausgibt entspricht auch keiner Logik, so dass ich nicht herausfinde woran es liegt. Ich habe schon diverse Zahlenformate versucht und Formeln geändert, aber es klappt nicht so wie es soll.

    Vielleicht hatte ja bereits jemand ein ähnliches Problem und kann mir den entsprechenden Denkanstoß geben.

    Danke und Beste Grüße Roman

    Betrifft: AW: Suche bei vorangestellter Null
    von: hary
    Geschrieben am: 26.03.2020 11:37:57

    Moin Roman
    Probier mal:
    =SUMMENPRODUKT((LINKS($A$1:$AE$8;2)=TEXT(LINKS(I12;2);"00"))*ZEILE($A$1:$A$8))
    gruss hary

    Betrifft: AW: Suche bei vorangestellter Null
    von: onur
    Geschrieben am: 26.03.2020 11:38:05

    Vermutlich liegt es dadran:
    LINKS(I12;2)

    Aber für Genaueres müsste man wissen, was in welcher Zelle steht und welches Format.
    Poste mal die (Beispiels-) Datei.

    Betrifft: da darfst Du nicht multiplizieren
    von: WF
    Geschrieben am: 26.03.2020 11:40:51

    Hi,

    aus 02 wird beim multiplizieren oder WERT(drumrum) 2.
    Du musst das also als Text behandeln mit WENN-Abfragen.

    Für exakteres braucht man Deine Datei.

    WF

    Betrifft: AW: Suche bei vorangestellter Null
    von: Daniel
    Geschrieben am: 26.03.2020 11:44:49

    Hi

    Also in Spalte A steht der Ausgabewert und die Plz-Bereiche beginnen in Spalte B.

    Deswegen: =SUMMENPRODUKT(($B$1:$AE$8=

    Gruß Daniel