Microsoft Excel

Herbers Excel/VBA-Archiv

Daten aus einer Zelle au mehrere verteilen

Betrifft: Daten aus einer Zelle au mehrere verteilen von: Wolle
Geschrieben am: 30.08.2004 17:37:44

Ich habe eine Excel Tabelle mit mit 6500 Adressdaten.

Leider sind die Namen mit Vor- und Nachname in einer Spalte.
Das ganze sieht momentan so aus.



















ABCDEF
AnredeNameNachnameStraßePLZOrt
HerrnManfred Mustermann Musterstraße 1642567Musterstadt
FrauEva Maria Schmidt Eisengasse 1067567Rückenhausen
FrauMargrit Gilbert-Schnepp Tipstraße 1267534Redstadt


Kann mir jemand den Code dafür verraten der die Tabelle so aussehen lässt?



















ABCDEF
AnredeNameNachnameStraßePLZOrt
HerrnManfredMustermannMusterstraße 1642567Musterstadt
FrauEva MariaSchmidtEisengasse 1067567Rückenhausen
FrauMargritGilbert-SchneppTipstraße 1267534Redstadt


Währe nett wenn mir da jemand helfen könnte, ist nämlich sehr wichtig.
Für eure Bemühungen bedanke ich mich schonmal im Voraus.

Gruß, W. Schmitz
  


Betrifft: Vor-und Nachnamen trennen von: Boris
Geschrieben am: 30.08.2004 17:48:55

Hi Wolle,

Name steht in A3.
Den Nachnamen in C3 mit Arrayformel:

{=WENN(ANZAHL(FINDEN({" von ";" zu ";" ob ";" van ";" de "};A3));TEIL(A3;MIN(WENN(ISTZAHL(FINDEN({" von ";" zu ";" ob ";" van ";" de "};A3));FINDEN({" von ";" zu ";" ob ";" van ";" de "};A3)))+1;99);TEIL(A3;MAX((TEIL(A3;SPALTE($1:$1);1)=" ")*SPALTE($1:$1))+1;99))}

Den Vornamen in B3 mit normaler Formel:
=GLÄTTEN(LINKS(A3;LÄNGE(A3)-LÄNGE(C3)))

Array-Formel: {geschweifte Klammern} nicht eingeben, sondern Formeleingabe mit Strg-Shift-Enter abschließen. Das erzeugt sie.

Grüße Boris


  


Betrifft: Kleiner Nachtrag zur Array-Formel von: Boris
Geschrieben am: 30.08.2004 17:50:27

Mein Standardspruch

Array-Formel: {geschweifte Klammern} nicht eingeben, sondern Formeleingabe mit Strg-Shift-Enter abschließen. Das erzeugt sie.

bezieht sich nur auf die {geschweiften Klammern} aussenrum. Die { } innerhalb der Formel werden per Hand eingegeben.

Grüße Boris


 

Beiträge aus den Excel-Beispielen zum Thema "Daten aus einer Zelle au mehrere verteilen"