Herbers Excel-Forum - das Archiv

Mehrere Daten aus Liste in Zelle wiedergeben.

Bild

Betrifft: Mehrere Daten aus Liste in Zelle wiedergeben.
von: samsplanet

Geschrieben am: 20.12.2006 11:01:05
Ich will, dass alle Daten einer Liste/Spalte (jedoch ohne leere Zellen) in einer einzelnen Zelle wiedergegeben werden. Ein Beispiel:
Folgende Werte der Spalte A:
A
1 affe
2
3 banane
4 brot
5
6 baum
Diese sollen alle in einer einzelnen Zelle wie folgt wiedergegeben werden:
"affe, banane, brot, baum"
Es sollen also nur die nichtleeren Zellen wiedergegeben werden.
Tips?
Danke und Gruss
sam
Bild

Betrifft: AW: Mehrere Daten aus Liste in Zelle wiedergeben.
von: Ludicla
Geschrieben am: 20.12.2006 11:08:37
Hey Samsplanet
warum sortiert Du nicht vorher - dann hast und nur noch "nichtleere Zellen"
und anschließend einfach verketten ?
Gruss Ludicla
Bild

Betrifft: AW: Mehrere Daten aus Liste in Zelle wiedergeben.
von: samsplanet
Geschrieben am: 20.12.2006 11:15:43
weil sich die liste ständig ändern kann.
oder gibt es eine methode um eine liste laufend zu sortieren?
die werte in der spalte sind übrigens von werten in einer anderen spalte abhängig, welche sich nicht sortieren lassen.
Bild

Betrifft: AW: Mehrere Daten aus Liste in Zelle wiedergeben.
von: Matthias G

Geschrieben am: 20.12.2006 11:25:10
Hallo Ludicla,
ich kann dir niur eine Benutzerdefinierte Funktion anbieten:

  • Alt+F11 zum Öffnen des VB-Editors
  • Menü Einfügen, Modul
  • ins erscheinende Codefenster dies reinkopieren:
    Function Liste(rng As Range) As String
    Dim z As Range, tmp As String
    For Each z In Intersect(rng, rng.Worksheet.UsedRange)
    If z.Value <> "" Then tmp = tmp & z & ", "
    Next z
    Liste = Left(tmp, Len(tmp) - 2)
    End Function
    

  • VB-Editor wieder schließen.

Dann geht diese Funktion:
Tabelle3
 AB
1affeaffe, banane, brot, baum, salz, hase, pfeffer
2  
3  
4banane 
5  
6brot 
7baum 
8  
9  
10salz 
11  
12  
13  
14  
15hase 
16  
17  
18pfeffer 
Formeln der Tabelle
B1 : =liste(A:A)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß Matthias
Bild

Betrifft: AW: Mehrere Daten aus Liste in Zelle wiedergeben.
von: samsplanet
Geschrieben am: 20.12.2006 11:38:52
danke matthias
funktioniert soweit nicht schlecht...
nur dass bei mir in B1 für leere zellen immer eine 0 angezeigt wird.
also: affe, 0, 0, banane, 0, brot, usw.
wo liegt der unterschied?
Bild

Betrifft: AW: Mehrere Daten aus Liste in Zelle wiedergeben.
von: Matthias G
Geschrieben am: 20.12.2006 11:43:38
Hallo,
sind die Zellen wirklich leer? Lösche mal eine der Zellen (markieren und "Entf" drücken) und schau was passiert.
Gruß Matthias
Bild

Betrifft: AW: Mehrere Daten aus Liste in Zelle wiedergeben.
von: samsplanet
Geschrieben am: 20.12.2006 11:50:49
nein, die zellen sind nicht leer. sie beinhalten folgende formel:
=WENN(AP6=1;;WENN(B6>$P$2;;B6))
Bild

Betrifft: AW: Mehrere Daten aus Liste in Zelle wiedergeben.
von: Matthias G

Geschrieben am: 20.12.2006 11:54:43
Hallo samsplanet,
Du unterdrückst also die Null über das Zellformat bzw. über die Optionen ("Nullwerte")?
dann schreib mal stattdessen
=WENN(AP6=1;"";WENN(B6>$P$2;"";B6))

also statt nichts zwischen die Semikola ein "".
Gruß Matthias
Bild

Betrifft: AW: Mehrere Daten aus Liste in Zelle wiedergeben.
von: samsplanet

Geschrieben am: 20.12.2006 11:58:38
danke matthias...
du bist mein ganz persönlicher held des tages ;-)
jinglebells
 Bild
Excel-Beispiele zum Thema "Mehrere Daten aus Liste in Zelle wiedergeben."
Suche über mehrere Tabellen Mehrere Schaltflächen für ein Makro
Suchbegriff über mehrere Tabellenblätter suchen. Benutzerdefinierte SVERWEIS-Funktion über mehrere Bereiche
Druck aus mehreren Tabellenblättern auf eine Druckseite AutoFilter über mehrere Arbeitsblätter setzen
Daten von mehreren Blättern auf ein Druckblatt Prozentuale Erhöhung über mehrere Arbeitsblätter hinweg
Werte in mehreren Spalten sortieren Textreihe auf mehrere Spalten mit fester Seitenlänge verteilen