Microsoft Excel

Herbers Excel/VBA-Archiv

Wert aus letztvorheriger Zelle übernehmen wenn <>0

Betrifft: Wert aus letztvorheriger Zelle übernehmen wenn <>0 von: claudia
Geschrieben am: 03.11.2014 12:04:03

Hallo,
ich brauche Hilfe :-)

ich habe in Spalte B entweder einen Wert stehen oder 0 (bzw. "", das kann ich ja steuern)
in Spalte A, Zeile 17 bspw möchte ich nicht den Wert der Spalte B, Zeile 17 haben, wenn dieser 0 oder "" ist, sondern den Wert aus der letzten vorherigen Zeile, wo ein Wert drin steht, hier bei mir im Beispiel B2.
Ich habe schon bissl gegoogelt, den letzten Zellwert der Spalte B will ich nicht, der erste ist es auch nicht, sondern wirklich derjenige, der drüber steht und nicht 0 oder "" ist. Spalte A ist hier händisch befüllt - damit ihr versteht, was ich meine. Meine Datei umfasst allerdings 350Tsd Zeilen, sodass mir die Zeit fehlt, das für alle zu machen.
Ich hoffe, das ist halbwegs verständlich beschrieben und freue mich auf gute Tipps.
Viele Grüße, Claudia

  

Betrifft: AW: Wert aus letztvorheriger Zelle übernehmen wenn <>0 von: Rudi Maintaire
Geschrieben am: 03.11.2014 12:15:42

Hallo,
so?

AB
1xxxyyy
26500065000
365000 
465000 
565000 
665000 
76500165001
865001 
965001 
1065001 
1165001 
126500265002
1365002 
1465002 
1565002 
1665002 

ZelleFormel
A2:Ax=WENN(B2>0;B2;A1)


Gruß
Rudi


  

Betrifft: AW: Wert aus letztvorheriger Zelle übernehmen wenn <>0 von: claudia
Geschrieben am: 03.11.2014 12:19:52

Hallo Rudi,
herzlichen Dank. Ja, genau so.
Ich hab viiiel zu kompliziert gedacht... Danke also für's Beantworten!
Viele Grüße, Claudia


 

Beiträge aus den Excel-Beispielen zum Thema "Wert aus letztvorheriger Zelle übernehmen wenn <>0"