Microsoft Excel

Herbers Excel/VBA-Archiv

Auswertung über mehrer Tabellenblätter


Betrifft: Auswertung über mehrer Tabellenblätter von: Stefan
Geschrieben am: 18.11.2017 11:08:37

Hallo,
in der beigefügten Datei im Tabellenblatt "Gesamtübersicht" soll in der gelben Makierung folgendes per Makro oder Formel berechnet werden.

Einmal Anzahl der Tage aus T1 und T3
zweitens die Prozent aus allen Tagen (siehe C11)
und zum Schluss die Stundenanzahl.

Das gleiche für die Tabellen T1 bis T4

Problem welches ich habe, es sind Tage doppelt vorhanden.
Sprich in T1 kann der 05.Jan enthalten sein sowie in T3 und T4 auch)
Es sollen daher nur die Tage einmal gerechnet werden, aber die geleisteten Stunden müssen trotzdem addiert werden.

Komme hier mit meinem Wissen leider nicht weiter.

https://www.herber.de/bbs/user/117725.xlsx

Danke für Eure Hilfe.

  

Betrifft: Warum noch einmal? von: onur
Geschrieben am: 18.11.2017 14:01:20

?


  

Betrifft: AW: Warum noch einmal? von: Stefan
Geschrieben am: 18.11.2017 19:47:10

Fehler meiner Seite.
Danke für den Hinweis


  

Betrifft: AW: zunächst sollte geklärt werden, ... von: ... neopa C
Geschrieben am: 18.11.2017 15:34:51

Hallo Stefan,

... warum Deine Stundenermittlung in T1!45:45 erst ab dem 18. März beginnt.
Und weiter, wenn Du schreibst: "Es sollen daher nur die Tage einmal gerechnet werden, aber die geleisteten Stunden müssen trotzdem addiert werden." sind zum Beispiel für Mitarbeiter A am 06.Mai in T1 8 und in T3 8,5 und am 22.7 sogar zweimal 9 h erfasst. Das kann bei einer Ärger geben.

Gruß Werner
.. , - ...


  

Betrifft: AW: zunächst sollte geklärt werden, ... von: Stefan
Geschrieben am: 18.11.2017 19:53:21

Dieses sind nur Beispiele.
Die Tabellenblätter bezeichnen Verschiedene Firmen.
Die Stunden sind nur Beispiele.

Die erste Frage von Dir verstehe ich gerade nicht so ganz.


  

Betrifft: AW: wenn dem so sein sollte ... von: ... neopa C
Geschrieben am: 19.11.2017 10:28:48

Hallo Stefan,

... dass "Die Tabellenblätter bezeichnen verschiedene Firmen" , dann dürften auch die "Mitglieder-Namen A-P" über die Firmen betrachtet unterschiedlich sein. Weshalb sollen diese dann aber namensbezogen addiert werden? Ergibt für mich keinen Sinn.

In Deiner Datei steht z.B. in T1!F45: =SUMMEWENN(F13:F37;"x";$D$2:$D$39) Dies wertet damit nur die Stunden vom 18. März bis 5. November aus und noch dazu versetzt für $D$2:$D$39.Ein Fehler?

Gruß Werner
.. , - ...


  

Betrifft: AW: wenn dem so sein sollte ... von: Stefan
Geschrieben am: 19.11.2017 19:46:00

Die Mitglieder sind die Gleichen, es handelt sich da um Freiberufliche und Ehrenamtliche.
Die Formel / Formeln in den Tabellentblätter sind falsch. Es soll schon von F2 bis Ende gerechnet werden. Das habe ich wohl im Stress übersehen.

Wichtig ist mir aber in erster Linie das letzte Tabellenblatt.

Warum es namensbezogen ist hat folgenden Hintergrund. Es kann durchaus sein das einer an einem Tag in verschiedenen Firmen etwas zu erledigen hat.


  

Betrifft: AW: nochmal nachgefragt ... von: ... neopa C
Geschrieben am: 20.11.2017 13:07:38

Hallo Stefan,

... es muss also keine Plausibilität geprüft werden, dass ein Mitglied an einem Tag in Summe auf mehr als auf z.B. 10 Stunden kommt?

Und, mit "Wichtig ist mir aber in erster Linie das letzte Tabellenblatt" meinst die "Gesamtübersicht" und nicht T4?


Gruß Werner
.. , - ...


  

Betrifft: AW: nochmal nachgefragt ... von: Stefan
Geschrieben am: 20.11.2017 15:55:07

... es muss also keine Plausibilität geprüft werden, dass ein Mitglied an einem Tag in Summe auf mehr als auf z.B. 10 Stunden kommt?

Richtig. Eine Plausibilität ist hier nicht relevant

... Und, mit "Wichtig ist mir aber in erster Linie das letzte Tabellenblatt" meinst die "Gesamtübersicht" und nicht T4?

Mit dem letzem Tabllenblatt meine ich die Gesamtübersicht.

VG und Danke schonmal


  

Betrifft: AW: dann Formel für Tage zu T1/t3 ... von: ... neopa C
Geschrieben am: 20.11.2017 17:16:46

Hallo Stefan,

... in B18:

=ZÄHLENWENN(INDEX('T1'!F$2:Z$49;;ZEILE(B1));"x")+ZÄHLENWENN(INDEX('T3'!F$2:Z$49;;ZEILE(B1));"x")-
SUMME(INDEX(ZÄHLENWENNS('T1'!A$2:A$49;'T3'!A$2:A$49;INDEX('T1'!F$2:Z$49;;ZEILE(B1));
WENN(INDEX('T3'!F$2:Z$49;;ZEILE(B1))="x";INDEX('T3'!F$2:Z$49;;ZEILE(B1));"-"));))


Formeln nach unten kopieren.

Gruß Werner
.. , - ...


Beiträge aus den Excel-Beispielen zum Thema "Auswertung über mehrer Tabellenblätter"