Herbers Excel-Forum - das Archiv

Spaltennummer eines zu suchenden Texts auslesen

Bild

Betrifft: Spaltennummer eines zu suchenden Texts auslesen
von: André Grunow

Geschrieben am: 07.04.2005 22:21:56
Hallo Leute!
Ich möchte folgendes erreichen:
Auf einem Tabellenblatt habe ich eine Liste von Kunden. Die Daten der Kunden stehen in verschiedenen Zellen (einer Spalte).
Eine der Spalten ist die laufende Nummer des Kunden - also eindeutig. Die Sortierung kann sich ständig ändern, und damit auch die Reihenfolge der laufenden Nummer (von oben nach unten gesehen).
Ich möchte nun erreichen, dass ich in dem einen Tabellenblatt folgende Funktion (oder VBA?) durchführen kann:
Suche in der Spalte D nach der laufenden Nummer "9" und lese der Reihe nach die Daten in dieser Zeile aus (Vorname in Spalte F, Nachname in Spalte G, Adresse in Spalte H, usw.). Wenn also herauskommt, dass die laufende Nummer "9" in der Zeile 34 gefunden wird (aufgrund irgendeiner Sortierung), dann findet er den Vornamen in F34, den Nachnamen in G34, usw.
Wie kann ich das erreichen?
Danke für jeden Hinweis
-André
Bild

Betrifft: AW: Spaltennummer eines zu suchenden Texts auslese
von: Josef Ehrensberger

Geschrieben am: 07.04.2005 22:30:12
Hallo André!
Das wäre was für SVERWEIS.
Tabelle1
 ABCDEFGH
1   Lfd Nr. VornameNameAdresse
2   1 VN 1NN 1Adr 1
3   2 VN 2NN 2Adr 2
4   3 VN 3NN 3Adr 3
5   4 VN 4NN 4Adr 4
6   5 VN 5NN 5Adr 5
7   6 VN 6NN 6Adr 6
8   7 VN 7NN 7Adr 7
9   8 VN 8NN 8Adr 8
10   9 VN 9NN 9Adr 9
11        
12Lfd Nr.VornameNameAdresse    
133VN 3NN 3Adr 3    
14        
Formeln der Tabelle
B13 : =SVERWEIS($A$13;$D$2:$H$10;3;FALSCH)
C13 : =SVERWEIS($A$13;$D$2:$H$10;4;FALSCH)
D13 : =SVERWEIS($A$13;$D$2:$H$10;5;FALSCH)
 


Gruß Sepp

P.S.: Rückmeldung nicht vergessen!


Bild

Betrifft: Danke für den schnellen und guten Tip!!!!!!
von: André Grunow
Geschrieben am: 08.04.2005 01:03:54
Das ging sehr schnell. Danke, Sepp.
 Bild
Excel-Beispiele zum Thema "Spaltennummer eines zu suchenden Texts auslesen"
Mehrfachauswahl aus ListBox auslesen Dateien aus Listbox auslesen und öffnen
Bereich in RefEdit-Element eingeben und auslesen Auslesen der Arbeitsmappeneigenschaften
UserName aus der Windows-Registry auslesen Eintrag aus der Win.ini auslesen
Einzelnes Zeichen aus einer InputBox-Eingabe auslesen Ausgewählte Arbeitsblätter auslesen
Mehrfachauswahl in ListBox auslesen