Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema ListBox
BildScreenshot zu ListBox ListBox-Seite mit Beispielarbeitsmappe aufrufen

Werte aus Matrix suchen - Formel

Betrifft: Werte aus Matrix suchen - Formel von: Johannes
Geschrieben am: 28.10.2020 11:28:04

Hallo zusammen,

ich suche für die Spalte L,N,P eine Formel, welche mir die Werte aus der angeführten Matrix sucht wenn, Hersteller und Position zusammenpassen.

Kann mir hier jemand weiterhelfen?

Hier die Datei:

  • https://www.herber.de/bbs/user/141145.xlsx


  • Vielen Dank im Voraus
    Grüße

    Betrifft: AW: Werte aus Matrix suchen - Formel
    von: SF
    Geschrieben am: 28.10.2020 11:30:40

    Hola,

    und welche Werte sollen jetzt genau wiedergegeben werden?
    Ein konkretes Beispiel wäre hilfreich.

    Gruß,
    steve1da

    Betrifft: AW: mit INDEX() und VERGLEICH() ...
    von: neopa C
    Geschrieben am: 28.10.2020 11:34:11

    Hallo Johannes,

    ... in L7 so: =INDEX($A:$I;;VERGLEICH(M7;$6:$6;0)) und Formel ziehend nach unten und dann nach N und P kopieren.

    Gruß Werner
    .. , - ...

    Betrifft: AW: mit INDEX() und VERGLEICH() ...
    von: johannes
    Geschrieben am: 28.10.2020 11:52:03

    Top - Danke, funktioniert auch!

    Betrifft: AW: bitteschön owT
    von: neopa C
    Geschrieben am: 28.10.2020 12:34:14

    Gruß Werner
    .. , - ...

    Betrifft: AW: Werte aus Matrix suchen - Formel
    von: peterk
    Geschrieben am: 28.10.2020 11:39:11

    Hallo

    In L7
    
    =WVERWEIS($M7;$B$6:$I$32;VERGLEICH($K7;$A$6:$A$32);FALSCH)
    
    


    Betrifft: AW: Werte aus Matrix suchen - Formel
    von: johannes
    Geschrieben am: 28.10.2020 11:51:40

    Super vielen Dank für die rasche Hilfe - wirklich DANKE!

    Betrifft: AW: Werte aus Matrix suchen - Formel
    von: Johannes
    Geschrieben am: 28.10.2020 16:40:05

    Hallo zusammen,

    hätte nun doch noch eine Frage:
    geht das ganze auch in umgekehrter Richtung - also ich habe eine Aufteilung nach Positionen und möchte nun nach Hersteller die Aufteilung machen.

    gibt es dafür eine enstprechte Formel?

    Hier die Beispieldatei:

    https://www.herber.de/bbs/user/141149.xls

    Vielen für eure Hilfe!

    Grüße

    Betrifft: AW: weiter dazu geht es oben im neuen thread owT
    von: neopa C
    Geschrieben am: 28.10.2020 17:10:15

    Gruß Werner
    .. , - ...

    Beiträge aus dem Excel-Forum zum Thema "Werte aus Matrix suchen - Formel"