Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn und Sverweis verschachteln

Betrifft: Wenn und Sverweis verschachteln von: Wolfgang
Geschrieben am: 07.09.2004 18:02:08

Hi,
habe folgendes Problem: Wenn bei einem Sverweis #NV erscheint soll die 1 eingetragen werden, ansonsten soll das Feld leer bleiben.

Meine Formel sieht so aus:

=WENN(SVERWEIS(G1;Personalstammdaten.xls!DB;11;0="";1;""))

Weiß jetzt nicht wo der Fehler ist.

Gruß Wolfgang

  


Betrifft: AW: Wenn und Sverweis verschachteln von: PeterW
Geschrieben am: 07.09.2004 18:23:55

Hallo Wolfgang,

ist zwar ein eigenartiges Konstrukt (welche Aufgabe steht dahinter?) aber das sollte so gehen:
=WENN(ISTNV(SVERWEIS(G1;Personalstammdaten.xls!DB;11;0));1;"")

Gruß
Peter


  


Betrifft: AW: Wenn und Sverweis verschachteln von: Wolfgang
Geschrieben am: 07.09.2004 18:29:33

Hallo Peter,

hier ist der Link zu der Aufgabe https://www.herber.de/bbs/user/10637.xls

Vielen Dank im voraus!

Gruß Wolfgang


  


Betrifft: AW: Wenn und Sverweis verschachteln von: PeterW
Geschrieben am: 07.09.2004 18:51:27

Hallo Wolfgang,

der Link zeigt keine Aufgabe sondern eine Arbeitsmappe. Ohne zu wissen, wohin die Formel gehört geht erst mal das Suchen los - und das erwartest du doch wohl nicht wirklich. :-)

Gruß
Peter


  


Betrifft: AW: Wenn und Sverweis verschachteln von: Wolfgang
Geschrieben am: 07.09.2004 19:08:54

Hallo Peter,

sorry - etwas unüberlegt von mir - wahr nicht so gemeint.

Ich bin ja noch lernfähig. Deine Formel habe ich jetzt eingesetzt und bin noch nicht am Ziel. Die 1 erscheint nicht. (im Tabellenblatt Merkzettel Zelle C7)

Gruß
Wolfgang


  


Betrifft: AW: Wenn und Sverweis verschachteln von: PeterW
Geschrieben am: 07.09.2004 19:30:58

Hallo Wolfgang,

lass mal das Leerzeichen am Anfang der Formelzelle weg. Bei einem Sverweis auf die gleiche Mappe musst du nur den benannten Bereich angeben. Sofern ich es weiter richtig verstehe willst du die Mitarbeiternummer mit dem Sverweis finden (oder eben nicht). Es reicht also:
=WENN(ISTNV(SVERWEIS(G1;DB;1;0));1;"")

Gruß
Peter


  


Betrifft: AW: Wenn und Sverweis verschachteln von: Wolfgang
Geschrieben am: 07.09.2004 19:56:48

Hallo Peter,

vielen Dank, folgender Sachverhalt: In dem "Tabellenblatt Datenbank" werden die Daten der Mitarbeiter eingegeben. Ist zum Beispiel das Feld für die Lohnsteuerkarte leer, soll im "Tabellenblatt Merkzettel, Zelle C7" die 1 erscheinen.

Gruß

Wolfgang


  


Betrifft: AW: Wenn und Sverweis verschachteln von: PeterW
Geschrieben am: 07.09.2004 20:06:04

Hallo Wolfgang,

das NV erscheint, wenn der Suchbegriff in der Suchmatrix nicht gefunden wird. Willst du bei einem gefundenen Wert einen Eintrag des Datensatzes abfragen dann so:
=WENN(SVERWEIS(G1;DB;11;0)="";1;"")
Was soll passieren, wenn in Spalte A der Suchbegriff (der in "Merkzettel"G1 steht) nicht gefuinden wird?

Gruß
Peter


  


Betrifft: AW: Wenn und Sverweis verschachteln von: Wolfgang
Geschrieben am: 07.09.2004 20:18:25

Hallo Peter,

richtig - daran habe ich gar nicht gedacht. Sinvoll wäre ein Text wie "Personalnummer nicht gefunden"

Gruß Wolfgang


  


Betrifft: AW: Wenn und Sverweis verschachteln von: PeterW
Geschrieben am: 07.09.2004 20:27:15

Hallo Wolfgang,

das könnte dann so gehen, gibt bestimmt andere Wege:
=WENN(ISTNV(SVERWEIS(G1;DB;1;0));"Pers.-Nr. nicht vorhanden";WENN(SVERWEIS(G1;DB;11;0)="";1;""))

Gruß
Peter


  


Betrifft: AW: Super Lob! +++ Vielen Dank +++ von: Wolfgang
Geschrieben am: 07.09.2004 20:34:32

Hallo Peter,

recht schönen Dank, für Deine Unterstützung!

Gruß Wolfgang


 

Beiträge aus den Excel-Beispielen zum Thema "Wenn und Sverweis verschachteln"