Microsoft Excel

Herbers Excel/VBA-Archiv

Mittelwert/ StabW in Spalte mit definierten Zeilen

Betrifft: Mittelwert/ StabW in Spalte mit definierten Zeilen von: 99MSU
Geschrieben am: 05.08.2008 17:09:34

Hallo zusammen,

ich habe eine Spalte mit Daten in den Zeilen z.B. 1 bis 1000. Die Daten liegen zwischen 4,5 und 8,5. Ich möchte nun für eine Mittelwert- bzw. Standardabweichungsberechnung nur die Werte berücksichtigen, die z.B. zwischen 5 und 8 liegen, da alle anderen Werte außerhalb der Toleranz sind. Gibt ed hierfür eine einfache Lösung?

Danek für die Hilfe.

  

Betrifft: AW: Mittelwert von: mpb
Geschrieben am: 05.08.2008 17:21:14

Hallo ???,

Mittelwert mit folgender Matrixformel:

=SUMME((A1:A10>5)*(A1:A10<8)*(A1:A10))/SUMME((A1:A10>5)*(A1:A10<8))

Eingabe der Formel mit STRG-SHIFT-ENTER, nicht mit ENTER beenden.

Gruß
Martin


  

Betrifft: AW: Mittelwert von: 99MSU
Geschrieben am: 05.08.2008 17:24:57

Danke, aber mir war eine analoge Lösung mit Hilfe des Summenproduktes bekannt. Da reicht normal ENTER, da es keine Matrixformel ist. Ich habe gehofft, es gibt etwas einfacheres.



Problematisch wird die Anwendung nämlich, wenn man die Standardabweichung oder den Range der Daten berechnen will.







Gruß



Lars


  

Betrifft: AW: Mittelwert von: mpb
Geschrieben am: 05.08.2008 17:44:36

Hallo Lars,

setze eines Autofilter auf die Spalte und definiere das benutzerdefinierte Kriteriul >5 UND <8. Verwende anschließend die Funktion TEILERGEBNIS zur Berechnung des Mittelwertes und der Standardabweichung, z.B.

Mittelwert:

=TEILERGEBNIS(1;A1:A12)

Standardabweichung:

=TEILERGEBNIS(7;A1:A12)

Gruß
Martin


 

Beiträge aus den Excel-Beispielen zum Thema "Mittelwert/ StabW in Spalte mit definierten Zeilen"