Datum zw. 2 Daten für jedes Monat erzeugen



Excel-Version: 97
nach unten

Betrifft: Datum zw. 2 Daten für jedes Monat erzeugen
von: Daniel
Geschrieben am: 12.04.2002 - 10:27:35

Hallo,

gegeben sind ein Anfangs und ein Enddatum (B1 und C1). Via Makro soll nun für jedes Monat dazwischen (inkl. Beginn und Enddatum) ein Datum in Spalte D erzeugt werden und zwar soll der Tag immer der gleiche sein (so wie Beginndatum)?

???
Daniel


nach oben   nach unten

?
von: André
Geschrieben am: 12.04.2002 - 10:33:51

könntest du die fragestellung bitte genauer formulieren

nach oben   nach unten

Re: Datum zw. 2 Daten für jedes Monat erzeugen
von: Flieger
Geschrieben am: 12.04.2002 - 11:29:35

Hallo Daniel,

meinst Du ungefähr so:

Sub test()
Dim anf As Date, ende As Date, i%, z%
anf = Cells(4, 2).Value
ende = Cells(4, 3).Value
z = 2
For i = Month(anf) To Month(ende)
Cells(z, 4).Value = Left(Format(CStr(anf), "DD.MM.YYYY"), 3) & Format(i, "00") & Right(Format(CStr(anf), "DD.MM.YYYY"), 5)
z = z + 1
Next
End Sub

Gruss
Flieger

nach oben   nach unten

Re: ?
von: Daniel
Geschrieben am: 12.04.2002 - 11:58:56

ich gebe im Feld B1 ein Beginndatum und in C1 ein Enddatum (z.B. 1.1.2001 und 1.1.2002).
Nun möchte ich in Spalte D alle Monate von Beginn bis Ende auflisten:
1.1.2001, 1.2.2001, ... 1.1.2002) wobei sich der Tag nach dem Beginndatum richten soll! (Nicht 1.1.2001, 5.2.2001)

Klar?
Daniel

nach oben   nach unten

Re: Datum zw. 2 Daten für jedes Monat erzeugen
von: Daniel
Geschrieben am: 12.04.2002 - 14:24:48

Hallo Flieger,

das ist nicht die gewünschte Lösung: ich möchte auch über mehrere Jahre alle Monate dazwischen auflisten; außerdem schreibt er ein völlig irres Datum in Spalte D (Anf.=1.1.2001; Ende=1.12.2001): 27.1.1927, 27.2.1927,...,27.12.1927
Wenn ich 1.1.2001 bis 1.1.2002 eingebe, dann schreibt er nur ein Datum (27.1.1927) weil er ja nur die Monate vergleicht

Herauskommen sollte aber 1.1.2001 bis 1.1.2002

Mein Ansatz war:
Sub Test()
Dim arrFiles As Variant
Range("H:H").ClearContents
Dim intCounter As Integer
For intCounter = 1 To Range("d1") + 1
With ThisWorkbook.Worksheets(1)
.Cells(intCounter, 8) = Range("b1") + (intCounter - 1) * 30
End With
Next intCounter
End Sub
b1 Anfangsdatum
c1 Enddatum
d1=RUNDEN(TAGE360(B1;C1)/30;0)
Da aber nicht jedes Monat 30 Tage hat, bleibt der Tag nicht der gleiche!

???

Daniel

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Datum zw. 2 Daten für jedes Monat erzeugen"