Zeilen zu Spalte, variable Länge

Bild

Betrifft: Zeilen zu Spalte, variable Länge
von: Micha
Geschrieben am: 17.06.2015 07:30:15

Hallo,
ich möchte Zeilen in eine Spalte transponieren. Die Zeilen haben dabei immer variable Spaltenanzahl. z. B.
a|b|c|d
a|1|2
a|b|c|d|e|f|g
...
Spalte:
a
b
c
d
a
1
2
a
b
c
usw.
Das ganze sollte per Formel lösbar und variabl sein.
Danke für Tipps!

Bild

Betrifft: unkompliziert mit Hilfsspalte
von: WF
Geschrieben am: 17.06.2015 08:14:52
Hi,
ich hab es auf 8 Spalten (bis H) beschränkt.
in J1 (Hilfsspalte) schreibst Du:
=INDEX(A:H;(ZEILE()-1)/8+1;REST(ZEILE()-1;8)+1)
runterkopieren
Das Ergebnis dann irgendwo per Arrayformel:
{=WENNFEHLER(INDEX(J:J;KKLEINSTE(WENN(J$1:J$99<>0;ZEILE($1:$99));ZEILE(X1)));"")}
runterkopieren
Salut WF

Bild

Betrifft: Ohne Hilfsspalte, dafür mit 2 nützlichen und ...
von: Luc:-?
Geschrieben am: 18.06.2015 01:45:07
…universell einsetzbaren UDFs in einer mehrzelligen MatrixFml auch kein Problem, Micha:
{=MTRANS(VSplit(GLÄTTEN(VJoin(MTRANS(A1:G3);;-2));;1))}
Die Texte dürfen bei dieser Fml allerdings keine Leerzeichen enthalten. Ist das der Fall, muss eine XlStandardFkt ergänzt wdn. In dieser FmlVariante bleiben Zahlen (bzw wdn TextZahlen zu) echte(n) Zahlen!
Die beiden UDFs findest du in letzter Version in dieser ArchivDatei.
Gruß, Luc :-?

Besser informiert mit …

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zeilen zu Spalte, variable Länge"