Microsoft Excel

Herbers Excel/VBA-Archiv

Summe in Zeile und Spalte VBA

Betrifft: Summe in Zeile und Spalte VBA von: Alex
Geschrieben am: 18.11.2012 12:09:20

Hallo werte Excel Profis

ich bastle gerade an einem VBA Befehl das folgendes kann:

Sobald in Zeile 6 etwas steht wird ab Zeile 7 alle Werte in der jeweiligen Spalte summiert und in der Zeile 5 der Spalte ausgegeben.

Weiter soll wenn in Spalte A was steht (ab Zeile 8), die ganze Zeile summiert werden und in Spalte B der Zeile ausgegeben werden.

Ich habe dazu folgende Idee, jedoch funktioniert das nicht ganz oder ich müsste viel zu viele _
Parameter definieren:



Dim Summe
Summe = Application.WorksheetFunction.Sum(ActiveSheet.Range("C:C"))
Range("C5").Value = Summe

Kann mir jemand weiter helfen?

Vielen Dank

  

Betrifft: und was wenn in (B) schon was steht ? kwT von: Matthias L
Geschrieben am: 18.11.2012 12:52:37




  

Betrifft: AW: Summe in Zeile und Spalte VBA von: Matze,Matthias
Geschrieben am: 18.11.2012 12:56:02

Hallo Alex
das würde einen Zirkelbezug ergeben.
In D5=Summe(C:C) muss in einer anderen Zelle berechnet werden


  

Betrifft: AW: Summe in Zeile und Spalte VBA von: Alex
Geschrieben am: 18.11.2012 13:10:15

Hallo, danke für die Antwort! wen etwas steht soll überschrieben werden.
Er soll ab Zeile 7 Zusammenzählen, somit gibt es doch keinen Zirkelbezug.


Gruss


  

Betrifft: AW: Summe in Zeile und Spalte VBA von: Matze,Matthias
Geschrieben am: 18.11.2012 13:11:38

Hallo Alex,
Ergebnis in C5 berechnet Summe unterhalb bis letzte Zeile

Sub Test ()
Dim LetzteZeile as Long
With Tabelle1
LetzteZeile = .Cells(Rows.Count, 3).End(xlUp).Row
Range("C5").Value = Application.WorksheetFunction.Sum(ActiveSheet.Range("C7:C" & LetzteZeile))
End With
End Sub
Matze


  

Betrifft: AW: Summe in Zeile und Spalte VBA von: Matze,Matthias
Geschrieben am: 18.11.2012 13:32:35

Hallo Alex,

ohne VBA so gemeint?

 ABCDE
5  13 12
6  100 Y
7x6123
839423
9x9423
1059423

Formeln der Tabelle
ZelleFormel
C5=WENN(C6="";"";SUMME(C7:C10))
D5=WENN(D6="";"";SUMME(D7:D10))
E5=WENN(E6="";"";SUMME(E7:E10))
B7=WENN(A7="";"";SUMME($C7:$E7))
B8=WENN(A8="";"";SUMME($C8:$E8))
B9=WENN(A9="";"";SUMME($C9:$E9))
B10=WENN(A10="";"";SUMME($C10:$E10))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Matze


  

Betrifft: AW: Summe in Zeile und Spalte VBA von: Gerd L
Geschrieben am: 18.11.2012 14:05:49

Hallo Alex!

Sub teste()

Dim rngCell As Range


Range("C5:" & Cells(5, Columns.Count).Address).ClearContents
Range("B8:" & Cells(Rows.Count, 2).Address).ClearContents

If Not Intersect(Range("C6:" & Cells(6, Columns.Count).Address), Cells.SpecialCells( _
xlCellTypeConstants)) Is Nothing Then
  For Each rngCell In Intersect(Range("C6:" & Cells(6, Columns.Count).Address), Cells. _
SpecialCells(xlCellTypeConstants)).Offset(-1)
      rngCell.FormulaR1C1 = "=SUM(R7C:R" & Application.Max(7, Cells(Rows.Count, rngCell.Column). _
End(xlUp).Row) & "C)"
      rngCell.Value = rngCell.Value
  Next
End If

If Not Intersect(Range("A8:" & Cells(1, Columns.Count).Address), Cells.SpecialCells( _
xlCellTypeConstants)) Is Nothing Then
  For Each rngCell In Intersect(Range("A8:" & Cells(Rows.Count, 1).Address), Cells.SpecialCells( _
xlCellTypeConstants)).Offset(, 1)
      rngCell.FormulaR1C1 = "=SUM(RC3:RC" & Application.Max(3, Cells(rngCell.Row, Columns.Count) _
.End(xlToLeft).Column) & ")"
      rngCell.Value = rngCell.Value
  Next
End If


End Sub
Gruß Gerd


  

Betrifft: AW: Summe in Zeile und Spalte VBA von: Alex
Geschrieben am: 18.11.2012 14:28:31

Hey Gerd

Das Teil ist super, danke dir vielmals und noch einen schönen Sonntag!
Gruss Alex


  

Betrifft: AW: Summe in Zeile und Spalte VBA von: Matze,Matthias
Geschrieben am: 18.11.2012 14:36:43

Hallo Zusammen,
cool Gerd, gleich mal als Vorlage gespeichert, danke.

habs mal kurz überflogen, Alex du wolltest ab Zeile 7 Rechnen:

ändere B8 zu B7 (oben)
und (unten) A8 zu A7

Matze


  

Betrifft: AW: Summe in Zeile und Spalte VBA von: Gerd L
Geschrieben am: 18.11.2012 14:57:39

Hallo Matthias!

Weiter soll wenn in Spalte A was steht (ab Zeile 8), die ganze Zeile summiert werden ...
So habe ich den 2. Teil gelesen.

Gruß Gerd


  

Betrifft: Ups, stimmt,... owT von: Matze,Matthias
Geschrieben am: 18.11.2012 15:08:37




 

Beiträge aus den Excel-Beispielen zum Thema "Summe in Zeile und Spalte VBA"