Microsoft Excel

Herbers Excel/VBA-Archiv

ANZAHL2 mit Bedingung zählen

Betrifft: ANZAHL2 mit Bedingung zählen von: Uwe
Geschrieben am: 16.09.2014 11:27:46

Hallo Excelfreunde

in der Formel =ANZAHL2(A1:B1) wird korrekterweise die Summe der Inhalte von A1 und B2 zusammengezählt.
Lässt sich auch ermitteln, dass nur der Inhalt gezählt wird, der ein Komma besitzt?

z.B.
A1= Lehmann, Heinz B1= Schmidt ANZAHL2= 1

Besten Dank für eine Lösung.

Gruß
Uwe

  

Betrifft: Finden ... von: Matthias L
Geschrieben am: 16.09.2014 11:35:22

Hallo

Hier ein Ansatz:

 ABC
1Lehmann, HeinzSchmidt2
21 1

Formeln der Tabelle
ZelleFormel
C1=ANZAHL2(A1:B1)
A2=WENN(ISTZAHL(FINDEN(",";A1;1));1;"")
B2=WENN(ISTZAHL(FINDEN(",";B1;1));1;"")
C2=SUMME(A2:B2)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Matthias


  

Betrifft: AW: Finden ... von: Uwe
Geschrieben am: 16.09.2014 12:14:12

Hallo,

danke. Die Lösung von WF ziehe ich aber vor.

Gruß Uwe


  

Betrifft: Ich auch ;-) owT von: Matthias L
Geschrieben am: 16.09.2014 12:14:54




  

Betrifft: =ZÄHLENWENN(A1:B1;"*,*") von: WF
Geschrieben am: 16.09.2014 11:45:20

.


  

Betrifft: AW: =ZÄHLENWENN(A1:B1;"*,*") von: Uwe
Geschrieben am: 16.09.2014 12:14:48

Hallo,

danke. Es hat mir geholfen.

Gruß Uwe


 

Beiträge aus den Excel-Beispielen zum Thema "ANZAHL2 mit Bedingung zählen"