Zahlenreihe mit Bedingungen anders wiedergeben

Bild

Betrifft: Zahlenreihe mit Bedingungen anders wiedergeben
von: Joerschi
Geschrieben am: 06.09.2015 20:27:19

Hallo liebes Forum,
folgende zwei Probleme versuche ich zu lösen bzw. habe Tomaten auf den Augen...
Skizze:
Userbild
Musterdatei: https://www.herber.de/bbs/user/100051.xlsx
Es gibt eine Zahlen-/Datenreihe B2:N2, welche stets von links nach rechts betrachtet wird.
1. Problem
In B4:N4 soll berechnet werden:
Von links aus gesehen soll bis inklusive des Maximums der obigen Zahlenreihe (also die 33 in E2) die Zahlen unverändert sein.
Ab der ersten Zahl rechts nach dem Maximum soll jede darüberstehende Zahl mit +10 addiert werden.
Nullen vor oder hinter der letzten Zahl größer 0 bleiben grundsätzlich immer Nullen (bedeutet, zwischen Zahlenwerten größer 0 sind sie erlaubt).
(in B5:N5 richtige Lösung manuell eingetragen)
2. Problem
In B7:N7 soll von links nach rechts aus der Zahlenreihe von B2:N2 die Zahlen unverändert von links nach rechts eingetragen werden, allerdings ohne die Nullen vorn und hinten (Ausnahme: Nullen zwischen Zahlen größer 0 bleiben erhalten).
(in B8:N8 wider richtige Lösung manuell eingetragen)
Hätte jemand Ansätze für eine Lösung?
(wahrscheinlich ist es total simpel und ich bin schon im Halbschlaf...)
Danke im Voraus und liebe Grüße
Joerschi

Bild

Betrifft: AW: Zahlenreihe mit Bedingungen anders wiedergeben
von: Daniel
Geschrieben am: 06.09.2015 21:11:36
Hi
formeln jeweils für die erste Zelle in Spalte B
problem 1:

=B2+WENN(ODER(B2=0;SPALTE(B2)<=VERGLEICH(MAX(2:2);2:2;0));0;10)
Problem 2:
=WENN(SPALTE(C7)>MAX(WENN($B$2:$N$2<>0;SPALTE($B$2:$N$2)));"";INDEX(2:2;1;MIN(WENN($B$2:$N$2<>0; SPALTE($B$2:$N$2)))-1+SPALTE(A1))) 

das ist eine Matrixformel, dh die Eingabe immer mit STRG+SHIFT+ENTER abschliessen.
Gruss Daniel

Bild

Betrifft: Verständnisfrage
von: Joerschi
Geschrieben am: 06.09.2015 21:32:39
Hallo Daniel,
besten Dank - funktioniert auch.
Allerdings eine Frage zur ersten Lösung zum Verständnis.
Mein Beispiel mit der Addition +10 war nur ein Beispiel, was ich dann mit einer Formel selbst adaptieren wollte.
Ich habe es jetzt probiert, bekomme es aber leider nicht hin.
In der späteren Formel soll dann statt +10 rechts der Zahl mit dem Maximum folgendes gerechnet werden: Maximum der Reihe + (Maximum der Reihe - Zahl darüber).
Für die Zelle F4 würde das in Zahlen bedeuten: 33 + (33-24) = 24
Für die Zelle G4 dann: 33 + (33-17) = 49 usw.
Könntest Du nochmal helfen?
Danke vorab und liebe Grüße, Joerschi

Bild

Betrifft: AW: Verständnisfrage
von: Daniel
Geschrieben am: 06.09.2015 21:56:51
ungern.
wenn du die frage gleich richtig stellst, kann ich auch gleich richtig antworten.
die Unsitte, das Problem erstmal anders zu schildern als es eigentlich ist, ist zwar weit verbreitet, aber ich kann trotzdem nicht verstehen, warum man das macht.
wie du das Maximum der Reihe ermittelst, kannst du doch aus meiner Formel ablesen.
Dann einfach nur das Maximum mit zwei multiplizieren und dann den Wert aus der Zelle abziehen.
Gruss Daniel

Bild

Betrifft: Erklärung + wieder auf "offen"
von: Joerschi
Geschrieben am: 06.09.2015 22:14:51
Hallo Daniel,
"die Unsitte, das Problem erstmal anders zu schildern als es eigentlich ist, ist zwar weit verbreitet, aber ich kann trotzdem nicht verstehen, warum man das macht."
Zumindest ich mache das aus zwei Gründen ao:
1. man will ja selbst lernen und wenn man den Kern der Formellösung kennt, lernt man selbst viel durch das anpassen anstatt einfach StrC & StrV bei einer Komplettlösung.
Wenn man es nicht hinbekommt, dann lieber nochmal nachfragen.
2. In dem Forum hier wird es zwar nett gehandhabt, dass man die Komplettlösung bekommt, aber ich halte es als Fragesteller den Helfern gegenüber trotzdem für "frech", wenn man direkt mal die komplette Lösung vorgekaut abfordert.
Hilfe soll ja Selbsthilfe nach sich ziehen, da sonst bei gleichen Problemen es sich der Fragesteller leicht macht und einfach mal fix ins Forum reinschreibt, auf das sich jemand am anderen Ende finden möge, der das Problem für ihn löst...
Von daher Sorry - war keine Absicht von mir. Auf jeden Fall vielen Dank für Deine Hilfe und Tipps.
Viele Grüße, Joerschi
PS: Bekomme es trotz des Tipps nicht hin und stelle die Frage daher vorsichtshalber wieder auf offen.
So sieht meine aktueller Versuch für Zelle B4 aus:

=2*MAX($B$2:$N$2)-WENN(ODER(B2=0;SPALTE(B2)<=VERGLEICH(MAX(2:2);2:2;0));0;B2)

Funktioniert prima für F4 bis J4, aber davor oder danach noch nicht :-(

Bild

Betrifft: AW: Erklärung + wieder auf "offen"
von: Daniel
Geschrieben am: 06.09.2015 22:41:30
HI
naja, wenn du selbst lernen willst, dann gibst du ziemlich schnell auf.
mit dem "keine komplett vorgekaute Lösung" hast du ja prinzipell recht, aber das bezieht sich dann eher auf Komplettlösungen wie "Urlaubskalender", "Terminplanungssoftware" usw.
Bei einzelnen Formeln ist es da sowieso schwer, was anderes hinzuschreiben als die "Komplettlösung" der Formel und dann erzeugt das Verändern der Problemstellung in der Regel Mehraufwand, insbesondere, weil "vereinfachte" Problemstellungen in der Regel auch zu "vereinfachten" Lösungen führen, die dann nicht auf das eigentliche Problem passen, und dann war der erste Lösungsansatz oft für die Tonne.
aber für dich mal eine Teillösung, mit der du dann selber weiterarbeiten kannst:

=Wenn(SPALTE(B2)<=VERGLEICH(MAX(2:2);2:2;0);Formel1;Formel2)
Formel1 ist die Formel, die berechnet werden soll, wenn du noch links vom Maximum bist
Formel2 ist die Formel, die berechnet werden soll, wenn du rechts vom Maximum bist
über das Gleichheitszeichen kannst du steueren, ob beim Maximum selbst Formel1 oder Formel2 angewendet werden soll.
Gruss Daniel

Bild

Betrifft: AW: Erklärung + wieder auf "offen"
von: Joerschi
Geschrieben am: 06.09.2015 22:56:33
Danke Dir Daniel.
So war es jetzt idiotensicher :-)
B4 =


=WENN(ODER(B2=0;SPALTE(B2)<=VERGLEICH(MAX(2:2);2:2;0));B2;2*MAX($B$2:$N$2)-B2)
Die anderen Hinweise werde ich mir annehmen.
Das eine Lösung schnell für die Katz sein kann, wenn sich das Problem auch nur leicht ändert, hatte ich so noch gar nicht auf dem Schirm. Aber stimmt natürlich, da durch die Helfer oft versucht wird, die Formel möglichst schlank anstatt allgemein zu halten.
Danke und Gruß in die Nacht
Joerschi

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zahlenreihe mit Bedingungen anders wiedergeben"