Microsoft Excel

Herbers Excel/VBA-Archiv

Frage zur Zufallszahl Formel

Betrifft: Frage zur Zufallszahl Formel von: Christian
Geschrieben am: 03.10.2014 09:45:25

Hallo an alle,

ich weiß ich stehe vermutlich nur auf dem Schlauch. Wie bekomme ich es hin, dass eine Zufallszahl ausgegeben wird, wenn A1 das Wort Nordrhein-Westfalen enthält (kommt ausschlielich als Teil des Textes vor, nie als kompletter Zellinhalt und es steht auch ausschließlich in der Mitte vom Text, nie am Anfang oder am Ende). Wenn es nicht vorkommt, soll auch nichts ausgegeben werden.

Danke und schönes Wochenende
Chris

  

Betrifft: =WENN(ZÄHLENWENN(A1;"*NRW*");ZUFALLSZAHL();"") von: {Boris}
Geschrieben am: 03.10.2014 09:53:47

VG, Boris


  

Betrifft: beim dritten mal hab ich Dich von: WF
Geschrieben am: 03.10.2014 10:01:01

Moin Boris,

bei N() warst Du 20 Minuten vor mir (hab's gesehen und nicht mehr abgeschickt)
jetzt 2 Minuten
nächstesmal: ?

WF


  

Betrifft: Jetzt hab ich extra... von: {Boris}
Geschrieben am: 03.10.2014 16:54:04

Hi Walter,

...schon so lang gewartet: https://www.herber.de/forum/messages/1384664.html

;-))

VG, Boris


  

Betrifft: Da kapierte ich nicht, was das soll. von: WF
Geschrieben am: 03.10.2014 18:43:39

.


  

Betrifft: Ich hab auch lang gebraucht... ;-)) oT von: {Boris}
Geschrieben am: 03.10.2014 22:40:35

...


  

Betrifft: mit FINDEN von: WF
Geschrieben am: 03.10.2014 09:55:26

=WENN(ISTZAHL(FINDEN("Nordrhein-Westfalen";A1));ZUFALLSZAHL();"")

WF


  

Betrifft: Zufallszahl - wenn bestimmter Text in Zelle von: Matthias L
Geschrieben am: 03.10.2014 09:55:45

Hallo

 BC
2wenn A1 das Wort Nordrhein-Westfalen enthält0,88961602
3wenn A1 das Ort Ordrhein-Westfalen enthält 
4den Text Nordrhein-Westfalen prüfen0,32609714

Formeln der Tabelle
ZelleFormel
C2=WENN(ISTZAHL(FINDEN("Nordrhein-Westfalen";B2));ZUFALLSZAHL();"")
C3=WENN(ISTZAHL(FINDEN("Nordrhein-Westfalen";B3));ZUFALLSZAHL();"")
C4=WENN(ISTZAHL(FINDEN("Nordrhein-Westfalen";B4));ZUFALLSZAHL();"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Matthias


  

Betrifft: AW: Frage zur Zufallszahl Formel von: Christian
Geschrieben am: 03.10.2014 11:36:00

Hallo ihr 3,

vielen Dank.

Es funktionieren beide Vorschläge (die von WF und Matthias waren identisch). Habe jetzt also die Qual der Wahl.

Schönes Wochenende
Christian


 

Beiträge aus den Excel-Beispielen zum Thema "Frage zur Zufallszahl Formel"