2 Suchkriterien mit Ausgabe einer bestimmten Zelle

Bild

Betrifft: 2 Suchkriterien mit Ausgabe einer bestimmten Zelle
von: Fabian Etzl
Geschrieben am: 10.08.2015 13:20:24

Hallo Community,
ich arbeite derzeit an einer Excelaufstellung die ca. 12.000 Artikel beinhaltet.
Die Aufgabe besteht darin, nach Möglichkeit jedem Artikel ähnliche Artikel aus der Tabelle zuzuordnen. Um eine Basis zur Auswahl ähnlicher Artikel herzustellen, habe ich 2 Spalten (Wort1; Wort2) mit jeweils einem prägnanten Wort zur Artikelbezeichnung.
Meine Überlegung war es nun, nach diesen Wörtern in der Liste der Artikelbezeichnung zu suchen und bei Treffern die Artikelnummer anzeigen zu lassen, die in einer weiteren Spalte steht.
Ich habe mich nun mehrere Tage mit diesem Problem beschäftigt und habe versucht, Lösungen im Internet zu finden. Allerdings bin ich mit Lösungen wie SVerweis oder Index/Vergleich mit mehreren Suchkriterien auf keinen grünen Zweig gekommen. Meine nächste Überlegung war dies mit einem Makro zu lösen, jedoch fehlt mir dazu die nötige Erfahrung.
Aufbau der Tabelle:
Artikelnummer; Artikelbezeichnung ; Wort 1 ; Wort 2 ;
---------------------------------------------------------------
19345498 ; Plasson Endstopfen 25 mm; Plasson; Endstopfen;
...
...
Wenn mir jemand bei dieser Problemstellung helfen könnte, wäre ich sehr dankbar :)
Ich bin neu hier und habe möglicherweise wichtige Punkte zur korrekten Problemdarstellung übersehen. Ich hoffe ihr könnt mir in diesem Fall Tipps zur Verbesserung geben.

Bild

Betrifft: z.B. mit INDEX() und AGGREGAT() oder auch ...
von: ... neopa C
Geschrieben am: 10.08.2015 13:28:01
Hallo Fabian,
... nur mit VERWEIS() wäre das möglich. Um es konkreter zu schreiben, wäre ein Beispieldatei sinnvoll
Gruß Werner
.. , - ...

Bild

Betrifft: AW: z.B. mit INDEX() und AGGREGAT() oder auch ...
von: Fabian Etzl
Geschrieben am: 10.08.2015 13:39:26
Hallo Werner,
vielen Dank für schnelle Anwort!
Ich habe hier eine Beispieldatei hochgeladen:
https://www.herber.de/bbs/user/99466.xlsx

Bild

Betrifft: AW: z.B. mit INDEX() und AGGREGAT() oder auch ...
von: ... neopa C
Geschrieben am: 10.08.2015 14:20:57
Hallo Fabian,
... Formel einfach ziehend nach unten kopieren:

 ABCDEFGHIJ
1ArtikelBezeichnungWort 1Wort 2 PlassonEndstopfen ArtikelBezeichnung
224807819Bedienungsschlüssel für KOS/UFHBedienungsschlüssel     24688273Plasson Endstopfen   25 mm
338546515Fermacell EstrichkleberFermacellEstrichkleber    29677040Plasson Endstopfen   30 mm
424688273Plasson Endstopfen   25 mmPlassonEndstopfen      
538569662PVC-KG Bogen   PVC-KGBogen      
638569108UA-Profil  50/40   UA-Profil50/40         
728918738Ziegelsturz        Ziegelsturz       
838564312Braas Wakaflex  BraasWakaflex      
9119785428Brandschutzmasse BDS-NBrandschutzmasseBDS-N      
10120402364Distanzschraube TX 6/10x120DistanzschraubeTX      
11120484402GSB 13RE SchlagbohrmaschineGSB13RE      
1238582805Hasse Kubivent HasseKubivent      
1352043364Klöber Dunstrohr VenductKlöberDunstrohr      
1424794854KOS-Keilovalschieber TWKOS-KeilovalschieberTW      
1518371428MQ-KS DN 125 90 GR, PN 10MQ-KSDN      
16120402246Paneltwistec TX 30 6,0 x 70 mm      SpaxPaneltwistecTX      
17120402286Paneltwistec TX 30 6,0 x 220 mm     SpaxPaneltwistecTX      
1834301496Salzsäure          Salzsäure       
1952210271Zink NackenblechZinkNackenblech      
2022366955Kessel Einfachrückstau DN 100KesselEinfachdruckstück      
2122366980Kessel Einfachrückstau DN 150KesselEinfachdruckstück      
2229677040Plasson Endstopfen   30 mmPlassonEndstopfen      
2329677041ABC "rot-blau-bunt"ABC"rot-blau-bunt"      

Formeln der Tabelle
ZelleFormel
I2=WENNFEHLER(AGGREGAT(15;6;A$1:A$12000/(C$1:C$12000=F$1)/(D$1:D$12000=G$1); ZEILE(A1)); "")
J2=WENN(I2="";"";SVERWEIS(I2;A:B;2;))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "2 Suchkriterien mit Ausgabe einer bestimmten Zelle"