Microsoft Excel

Herbers Excel/VBA-Archiv

Werte einer Spalte zählen ohne Redundanzen



Excel-Version: 8.0 (Office 97)

Betrifft: Werte einer Spalte zählen ohne Redundanzen
von: Olaf
Geschrieben am: 28.08.2002 - 16:45:27

Hallo,

wie kann ich feststellen, wieviele verschiedene Einträge eine Spalte hat? Dabei dürfen redundante Werte nicht mitgezählt werden!


  

Re: Werte einer Spalte zählen ohne Redundanzen
von: Folker
Geschrieben am: 28.08.2002 - 16:57:32

Eine Möglichkeit ist über die Spezialfilterfunktion die Spalte an eine andere Stelle zu kopieren und Duplikate auszuschliessen. Dann mit der Zählen Funktion.
Oder du benutzt die Zählenwenn Funktion neben der Spalte:
=zählenwenn($A$1:$A$100;A1) und runterkopieren
dann am Ende die 1er Zählen:
=zählenwenn(B1:B100;1)
  

Re: Werte einer Spalte zählen ohne Redundanzen
von: Martin Beck
Geschrieben am: 28.08.2002 - 17:51:21

Hallo Folker,

Deine Lösung zählt, wie oft Werte genau einmal vorkommen. Olaf möchte jedoch m.E alle vorkommenden Werte genau einmal zählen. Die hierzu notwendigen Formeln gibt's unter

http://www.excelformeln.de/formeln.html?welcher=42

Gruß
Martin Beck

  

Re: Werte einer Spalte zählen ohne Redundanzen
von: Olaf
Geschrieben am: 29.08.2002 - 11:22:16

Danke Martin!
Danke Folker!

Kann beide Formeln für unterschiedliche Sachverhalte nutzen!
Vielen Dank!
Olaf


  

Noch was... :(
von: Olaf
Geschrieben am: 29.08.2002 - 11:57:45

Diese Funktion klappt super, Martin! Nun noch eine Frage! Ich möchte dass diese Auswertung nur gemacht wird, wenn in der Spalte links ein bestimmter Wert steht.

Abstrakt:

wenn (A:A="0815",Summe(Häufigkeit...etc)
funktioniert aber so nicht!
Woran liegts?`

Olaf

  

Re: Noch was... :(
von: Martin Beck
Geschrieben am: 29.08.2002 - 12:16:48

Hallo Olaf,

wo in Spalte A steht der kritische Wert? Falls in A1 dann z.B.

=WENN(A1=33333;SUMME((HÄUFIGKEIT(A:A;A:A)>0)*1);"")

Gruß
Martin Beck

  

Re: Noch was... :(
von: olaf
Geschrieben am: 29.08.2002 - 13:52:14

Das Problem ist, dass der Wert mehrfach vorkommt.
Die ganze Spalte muss auf den kritischen Wert überprüft werden und nur dann, wenn er gefunden wird, soll die Häufigkeit der Werte von Spalte B ausgewertet werden.

Abstrakt formuliert:
Wenn der Wert x in Spakte A gefunden wird, berechne mir die Häufigkeit der Werte, die in der gleichen Zeile in B stehen!

Kompliziert, was!?

  

Nur um sicher zu gehen ...
von: Martin Beck
Geschrieben am: 29.08.2002 - 14:10:31

... daß ich Dich richtig verstehe. Der Tabellenaufbau ist z.B. wie folgt:


MS Excel von Martin Beck an olaf
 AB
116
226
336
426
517
627
737
848
938
1029
1118
1227


Kritischer Wert in Spalte A sei "2". 2 kommt 5 mal vor und zwar in folgenden Kombinationen mit Spalte B:

2 6
2 6
2 7
2 9
2 7

Gesucht ist für diese Kombinationen die Anzahl der unterschiedlichen Werte in Spalte B, hier also das Ergebnis 3.

Ist das so korrekt?

Gruß
Martin Beck

 

Beiträge aus den Excel-Beispielen zum Thema "Werte einer Spalte zählen ohne Redundanzen"