Microsoft Excel

Herbers Excel/VBA-Archiv

SVERWEIS ausfüllen

Betrifft: SVERWEIS ausfüllen von: Josef
Geschrieben am: 14.09.2004 10:08:31

Hallo,

Ich möchte in eine Zelle die Formel SVERWEIS eintragen und mit VBA nach unten ausfüllen. Die Anweisungen sehen wie folgt aus.

Dim fillRange As Range
Dim sourceRange As Range
Workbooks("Mappe2").Activate
Sheets("Tabelle1").Select
Range("F3").FormulaLocal = "=SVERWEIS(K3;Tabelle1!$A$3:D7;3)"
Set sourceRange = Worksheets("Tabelle1").Range("F3:F7")
Set fillRange = Worksheets("Tabelle2").Range("F3:F7")
sourceRange.AutoFill Destination:=fillRange

Der Fehler taucht in der letzten Zeile auf. Weiß jemand, was hier nicht stimmt oder wie man es anders machen kann.

Danke
Josef

  


Betrifft: AW: SVERWEIS ausfüllen von: Udo
Geschrieben am: 14.09.2004 10:17:56

Die Bereiche können nicht in zwei verschiedenen Blättern sein.

Udo


 

Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS ausfüllen"