Hyperlinks gehen bei HTML-Export verloren



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Hyperlinks gehen bei HTML-Export verloren
von: Jens Rottmann
Geschrieben am: 16.05.2002 - 18:30:08

Hallo!

Ich habe folgendes Problem, bei dem ich hoffe, dass mir jemand behilflich sein kann:

Ich erzeuge in Excel über die folgende Formel Hyperlinks, die ich anschließend über den Standard Excel in HTML-Export (unter Datei: Als HTML speichern) als Tabelle innerhalb eines HTML-Templates veröffentlichen möchte:

=WENN(UND(NICHT(ISTLEER($B3));NICHT($B6="offen"));HYPERLINK("/Einzelreport/Quality-Report_Nr._"&$A3&".htm"; "Report");"")

Die Erstellung der Hyperlinks funktioniert damit in Excel wunderbar. Lediglich wenn ich den notwendigen HTML-Export durchführe wird der Hyperlink "verschluckt" und es wird nur noch der Name des Hyperlinks angezeigt, ohne das er irgendeine Funktionalität besitzt.

Ich könnte mir nun vorstellen, dass mir entweder eine andere Formel oder ein HTML-Export-Makro weiterhelfen kann.
Einige Export-Makros aus dem Forum habe ich schon erfolglos getestet. Hyperlinks wurden auch dort nicht übernommen.

Info: Einen fest verdrahteten Hyperlink kann ich über die Standard-HTML-Schnittstelle exportieren. Dieser ist danach noch funktional aktiv. Erst wenn ich die Erstellung verformel funktioniert der Export nicht mehr.

Besten Dank und Grüße

Jens


nach oben   nach unten

Re: Hyperlinks gehen bei HTML-Export verloren
von: Hans W. Herber
Geschrieben am: 18.05.2002 - 09:45:48

Hallo Jens,

das kann weder über Excel noch über meine in den VBA-Beispielen hinterlegte Routinen funktionieren. Die Hyperlinkformel ist für Excel kein Zell-Hyperlink; Du wirst es feststellen, wenn Du dies über "ActiveCell.Hyperlinks.Count" abfragst.
Man kann das Problem über eine VBA-Routine lösen, wobei allerdings erschwerend die Zusammensetzung der Formel hinzukommt.
Meines Erachtens sollte man - wenn es sich immer um die gleiche Zelle(n) handelt, auf die Formel verzichten und über VBA an der(n) betreffenden Stelle(n) einen echten Hyperlink unter Berücksichtigung der Bedingungen eintragen lassen.

hans


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Hyperlinks gehen bei HTML-Export verloren"