Microsoft Excel

Herbers Excel/VBA-Archiv

Summenprodukt

Betrifft: Summenprodukt von: Ingo
Geschrieben am: 12.08.2008 11:19:26

Hallo zusammen,

ich möchte aus einer Datenbank bestimmte Beträge (Beträge in Spalte T) addieren, sofern die Bezeichnung der Buchung in Spalte D einen bestimmten Wert enthält (z.B. V0220). Allerdings ist dieser Wert nur ein Teil eines mehrstelligen Codes (V0220U4564613). Gibt es eine Möglichkeit dies mit der Funktion Summenprodukt zu lösen?

Ich kam schon bis

<b>=SUMMENPRODUKT(LINKS(G2:G11507;5)="V0220")*(T2:T11507<0)*(T2:T11507)</b>

aber funktionieren will es noch nicht.

Kann mir jemand helfen?

Danke und Gruß,

Ingo

  

Betrifft: AW: Summenprodukt von: Beate Schmitz
Geschrieben am: 12.08.2008 11:28:22

Hallo Ingo,

=SUMMENPRODUKT((LINKS(G2:G11507;5)="V0220")*(T2:T11507<0)*(T2:T11507))

Gruß,

Beate


  

Betrifft: AW: Summenprodukt von: Ingo
Geschrieben am: 12.08.2008 11:34:52

Hallo Beate,

vielen Dank, aber klappen will es noch nicht. Kann es sein, dass es daran liegt, dass es sich bei V0220 um einen Teil eines Textes handelt?

Leider kenne ich keine "enthält"-Funktion bei einem Summenprodukt.


  

Betrifft: AW: Summenprodukt von: David
Geschrieben am: 12.08.2008 11:54:16

Hallo Beate,

bei mir funzt Ingos Vorschlag. Hast du auf die Klammern geachtet? Prüfe auch ob in dem String "V0220" auch Nullen enthalten sind oder evtl. der Buchstabe O!

Alternativ kannst du mal einen Versuch mit einer anderen Variante bei Summenprodukt machen.
Eine 'Enthält'-Funktion kannst du mit SUCHEN und FINDEN realisieren, auch dazu ein Beispiel.

Tabellenblattname: Tabelle1
 

A

B

C

D

E

F

G

1

V0220U4564613

-1

100

2200

2200

 

V0220

2

V0221U4564614

-1

200

 

 

 

 

3

V0222U4564615

-1

300

 

 

 

 

4

V0223U4564616

-1

400

 

 

 

 

5

V0223U4564616

-1

500

 

 

 

 

6

V0223U4564616

-1

600

 

 

 

 

7

V0223U4564616

-1

700

 

 

 

 

8

V0221U4564620

-1

800

 

 

 

 

9

V0222U4564621

-1

900

 

 

 

 

10

V0220U4564622

-1

1000

 

 

 

 

11

V0220U4564623

-1

1100

 

 

 

 


Benutzte Formeln:
D1: =SUMMENPRODUKT(--(LINKS(A1:A11;5)="V0220");--(B1:B11<0);(C1:C11))
E1: =SUMMENPRODUKT(--(NICHT(ISTFEHLER(SUCHEN($G$1;A1:A11))));--(B1:B11<0);(C1:C11))



Rückmeldung wäre nett.

Gruß

David


  

Betrifft: AW: Summenprodukt von: Reinhard
Geschrieben am: 12.08.2008 11:42:08

Hi Ingo,

Tabellenblatt: [Mappe1]!Tabelle1
  |  A  |     B     |   C  |
--|-----|-----------|------|
1 | 101 | V02202345 |    1 |
--|-----|-----------|------|
2 |     | V02214455 |   10 |
--|-----|-----------|------|
3 |     | V02202345 |  100 |
--|-----|-----------|------|
4 |     | V02214455 | 1000 |
---------------------------'
Benutzte Formeln:
A1:  =SUMMENPRODUKT((LINKS(B1:B4;5)="V0220")*(C1:C4))



Gruß
Reinhard


  

Betrifft: AW: Summenprodukt von: Andre
Geschrieben am: 12.08.2008 11:48:13

Hallo Ingo,

theoretisch sollte deine Formel funktionieren, allerdings verstehe ich nicht, warum du alle Beträge <0 summieren willst, >0 scheint mir grundsätzlich sinnvoller (oder die Bedingung ganz weglassen).

Gruß,

Andre


  

Betrifft: AW: Summenprodukt von: Ingo
Geschrieben am: 12.08.2008 11:52:19

Danke Reinhard und Andre!!!

Klappt prima!