Alternative zur Funktion "rang.gleich"

Bild

Betrifft: Alternative zur Funktion "rang.gleich"
von: Charsten Kerner
Geschrieben am: 02.07.2015 20:28:32

Hallo zusammen,
ich suche eine alternative zu der Funktion rang.gleich (Benutzung Excel 2013)
Als Beispiel gibt es Zeiten die zum Teil unterschiedlich sind, aber auch gleich. Wichtig ist mir hier nicht die Platzierung sondern: "erst bester Wert", "2. Bester Wert" usw.
Als Beispiel "rang.gleich" (so benötige ich es nicht):
Zeit: Rang:
10 min. 1
40 min. 4
10 min. 1
35 min. 3
Aufgelöst hätte ich das gern aber so, (wievielt beste Zeit)
Zeit: Beste Zeit:
10 min. 1
40 min. 3
10 min. 1
35 min. 2
gibt es dafür eine Lösungsmöglichkeit? Würde mich über Hilfe freuen. Danke im Voraus.
Nette Grüße Charsten

Bild

Betrifft: AW: Alternative zur Funktion "rang.gleich"
von: Daniel
Geschrieben am: 02.07.2015 21:13:56
HI
guckst du:
http://www.excelformeln.de/formeln.html?welcher=230
Gruß Daniel

Bild

Betrifft: AW: Alternative zur Funktion "rang.gleich"
von: Charsten Kerner
Geschrieben am: 02.07.2015 21:43:17
Hallo,
genau das ist es Daniel. Vielen Dank für den Link. Damit ist mein Problem gelöst.
Es grüßt Dich Charsten

Bild

Betrifft: AW: Alternative zur Funktion "rang.gleich"
von: Charsten Kerner
Geschrieben am: 03.07.2015 16:10:24
Hallo Werner,
die Formel ist sogar noch etwas besser wie ich finde, weil ich in meinem Fall bspw. in der obersten Zelle, die Anzahl der Platzierungen ermitteln kann. Brauche ich jetzt zwar in meiner Liste nicht unbedingt, vielleicht aber später doch mal zu Auswertungszwecken.
Dank auch an Dich für Deine Mühe.
Nette Grüße
Charsten

Bild

Betrifft: Ermittlung des Ranges ohne Platzierungslücken ...
von: der neopa C
Geschrieben am: 03.07.2015 09:53:56
Hallo Charsten,
... mit der Formel von Josef Burch bist Du schon bestens beraten!
Trotzdem stelle ich hierzu mal noch eine weitere Alternative vor, die im Ergebnis identisch mit dem der Langformel aus aus http://www.excelformeln.de/formeln.html?welcher=230 ist. Mit dieser werden bei vorkommenden Fehlerwerten in den Ausgangsdaten in Spalte A diese in die Ergebnisse übernommen (bei der Kurzformel von Josef Burch wird dann als Ergebnis stets 0 ausgewiesen).
Meine (MATRIX)-Formel:


{=SUMME((A3<>"")*(HÄUFIGKEIT(WENN(A$3:A$99>=A3;A$3:A$99);A:A)>0))}

ist im Kern gleich der von Sepp und (unwesentlich) länger.
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Alternative zur Funktion "rang.gleich""