Format(CCur(ComboBox3), "#,##0.00")

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
TextBox
Bild

Betrifft: Format(CCur(ComboBox3), "#,##0.00")
von: ray
Geschrieben am: 21.04.2005 09:07:00
Hallo, ich habe Probleme...
mit
Format(CCur(TextBox2), "#,##0.00")
übergebe ich von einer UF den Inhalt von tb2 an sheet liste. (Ich hoffe als zahl)
In einer ComboBox auf einer anderen UF lasse ich mir diese Tabelle anzeigen. Den oben geänderten Wert übergebe ich so an:
Worksheets("datenOutput").Range("b3").Value = Format(CCur(ComboBox3), "#,##0.00")
in sheet datenOutput will ich diesen Wert verarbeiten:
=SVERWEIS(B2;liste!B2:H619;3;FALSCH) 'das ergibt #NV
Wenn ich in sheet liste auf die geänderte zelle klicke und über die menüschaltfläche 0000 versuche dezimalstellen hinzuzufügen, dann passiert nix. Gucke ich auf Zellenformieren, dann ist die Zelle aber als zahl definiert.
Irgendwas stimmt hier nicht....
Bitte um Hilfe aus dem bewölkten kalten Hamburg
ray

Bild

Betrifft: AW: Format(CCur(ComboBox3), "#,##0.00")
von: Waltraud
Geschrieben am: 21.04.2005 09:25:56
Die funktion format hat als Rückgabewert einen String.
Würde es nicht reichen, wenn du dem Wert in deinem Tabellenblatt ein Format zuweist.
Bild

Betrifft: bitte etwas genauer
von: ray
Geschrieben am: 21.04.2005 09:36:40
Hi,
"Die funktion format hat als Rückgabewert einen String."
bedeutet das, daß ich damit aus text keine zahl bekomme?
"Wert in deinem Tabellenblatt ein Format zuweist."
Ich kann die tabelle nicht direkt bearbeiten nur über die Eingaben der UF.
Danke und Gruß
ray
Bild

Betrifft: AW: bitte etwas genauer
von: Waltraud
Geschrieben am: 21.04.2005 09:46:56
Worksheets("datenOutput").Range("b3").Value = CCur(ComboBox3)
Worksheets("datenOutput").Range("b3").NumberFormat = "#,##0.00"
Bild

Betrifft: Vielen Dank - Große Hilfe; oT
von: ray
Geschrieben am: 21.04.2005 10:06:05
ot
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Summen bilden"