Zur Zahlenreihe Werte nach einem Gradient addieren

Bild

Betrifft: Zur Zahlenreihe Werte nach einem Gradient addieren
von: Surminder
Geschrieben am: 15.09.2015 16:11:34

Hallo Excel-Profis,
ich habe eine Zahlenreihe und möchte wissen wie viel ich zu jedem Wert in der Reihe dazuaddieren kann ohne das ein Gradient bzw. Steigung (egal, ob positiv oder negativ) von z verletzt wird.
D.h. zu jedem Wert der Reihe (x1,x2,x3,...) den höchsten Wert y dazuaddieren ohne das der Gradient (x1-x2) größere als z, aber auch (x2-x3) größere als z ist.
In Worten ausgedrückt: Es sollen die maximalen Werte (y) gefunden werden, die zu jedem Wert der Reihe dazuaddiert werden können ohne das z verletzt wird. Z ergibt sich aus jeweils zwei aneinanderliegende Werte der Reihe x. D.h. für die Lösung für x2 muss beachtet werden, dass x1-x2 nicht größer als z wird und auch x2-x3 nicht größer als z wird. Diese größt möglichen Werte suche ich für die ganze Reihe der Werte x.

Als Beispiel:
Werte Reihe x: x1: 12; x2: 14; x3: 10; z = 6
Dann darf zu x2 maximal 2 dazuaddiert werden. y=2
Vielen Dank schonmal für euere Hilfe.

Bild

Betrifft: AW: Zur Zahlenreihe Werte nach einem Gradient addieren
von: ingoG
Geschrieben am: 15.09.2015 16:28:38
Hallo ,
wenn ich es richtig verstanden habe sollte folgende Matrixformel funzen:
=WENN($C$1-MAX(ABS(A2:A3-A3:A4))>=0;$C$1-MAX(ABS(A2:A3-A3:A4)))
Eingabe abschließen mit Strg-Shift-Enter
in a2-a4 stehen die X-werte und in C1 der Z-Wert.
Wenn die Differenz <0 wird , wird Falsch ausgegegeben
Ich hoffe, das hilft Dir weiter...
Gruß Ingo

Bild

Betrifft: AW: Zur Zahlenreihe Werte nach einem Gradient addieren
von: Surminder
Geschrieben am: 15.09.2015 18:36:26
Vielen Dank schonmal Ingo!
Aber leider zeigt die Formel mir nicht die richtigen Werte an.
Hat es bei dir geklappt?
z.B. spuckt die Formel die y-Werte heraus bei z= 6:
x =13
x1=11 --- y1= 4 -- Richtig wäre: 5
x2=10 --- y2= 3 -- Richtig wäre: 7
x3=12 --- y1= 3 -- Richtig wäre: 4
x4=12

Bild

Betrifft: AW: Zur Zahlenreihe Werte nach einem Gradient addieren
von: Surminder
Geschrieben am: 15.09.2015 18:47:59
P.S. wo kann ich nochmal einstellen, da ich bei einer Antwort auf diesen Thread eine E-Mail Nachricht bekomme?

Bild

Betrifft: AW: Zur Zahlenreihe Werte nach einem Gradient addieren
von: Surminder
Geschrieben am: 15.09.2015 23:28:59
Hallo,
mit der Formel hier http://www.clever-excel-forum.de/thread-2894-page-2.html
konnte mein Problem gelöst werden.
Damit ist das Problem vorerst denke ich gelöst.
Vielen dank für euere Hilfe
Surminder

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zur Zahlenreihe Werte nach einem Gradient addieren"