Microsoft Excel

Herbers Excel/VBA-Archiv

Wahrheitsprüfung

Betrifft: Wahrheitsprüfung von: Rebecca
Geschrieben am: 22.08.2008 07:15:50

Hallo,
ich möchte gerne in der Zelle D2 auf dem Tabellenblatt Zahlung eine Prüfung einbauen:
Es soll geprüft werden, ob Herr Meier berechtigt ist, die Zahlung durchzuführen.
Wenn ja, soll berechtigt erscheinen, wenn nicht soll nicht berechtigt erscheinen.
Was Herr Meier bezahlt hat steht im Tabellenblatt Zahlung, die Berechtigung steht im Tabellenblatt Berechtigung.
Wenn die ZelleA2 leer ist, soll D2 auch leer sein.
Ich habe versucht, das mit einer Wennfunktion hinzukriegen, aber das klappt überhaupt nicht.
Kann jemand helfen?
Gruss
Rebecca

https://www.herber.de/bbs/user/54802.xls

  

Betrifft: AW: Wahrheitsprüfung von: ede
Geschrieben am: 22.08.2008 07:55:37

hallo,
meinst du so?
https://www.herber.de/bbs/user/54803.xls

gruss


  

Betrifft: AW: Wahrheitsprüfung von: Rebecca
Geschrieben am: 22.08.2008 08:42:02

Hallo Ede,
recht herzlichen Dank, genau das habe ich gemeint :-)
Schönen Tag noch.
Gruss
Rebecca


  

Betrifft: AW: Wahrheitsprüfung von: Erich G.
Geschrieben am: 22.08.2008 08:35:38

Hi Rebecca,
oder vielleicht so?

 D
1geprüft
2berechtigt
3nicht berechtigt
4fehlt in Liste

Formeln der Tabelle
ZelleFormel
D2=WENN(ISTZAHL(SVERWEIS(A2;berechtigt;2;0)); WENN(SVERWEIS(A2;berechtigt;2;0)>=C2;"";"nicht ")&"berechtigt";"fehlt in Liste")
Namen in Formeln
ZelleNameBezieht sich auf
D2berechtigt=Berechtigung!$A$1:$B$10

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Wahrheitsprüfung von: Rebecca
Geschrieben am: 22.08.2008 08:55:27

Hallo Erich,
sorry, hatte mich eben die ganze Zeit mit dem Testen beschäftigt.
Deine Lösung ist auch klasse. Aber wenn ich die Formel für die Spalte durchziehe und in der zu prüfenden Spalte gar nichts steht, wird keine leere Zeile bei der Prüfung angegeben, sondern: fehlt auf der Liste. Kann man das auch noch mit einbauen???
Wäre klasse.
Gruss
Rebecca


  

Betrifft: AW: Wahrheitsprüfung von: Erich G.
Geschrieben am: 22.08.2008 09:17:31

Hi Rebecca,
so gehts z. B.:

 ABCD
1NameReNrBetraggeprüft
2Meier123201nicht berechtigt
3Müller111300berechtigt
4Schulze11177fehlt in Liste
5  xfehlt in Liste
6    

Formeln der Tabelle
ZelleFormel
D2=WENN(A2&C2="";"";WENN(ISTZAHL(SVERWEIS(A2;berechtigt;2;0)); WENN(SVERWEIS(A2;berechtigt;2;0)>=C2;"";"nicht ")&"berechtigt";"fehlt in Liste"))
D6=WENN(A6&C6="";"";WENN(ISTZAHL(SVERWEIS(A6;berechtigt;2;0)); WENN(SVERWEIS(A6;berechtigt;2;0)>=C6;"";"nicht ")&"berechtigt";"fehlt in Liste"))
Namen in Formeln
ZelleNameBezieht sich auf
D2berechtigt=Berechtigung!$A$1:$B$10
D6berechtigt=Berechtigung!$A$1:$B$10

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: Wahrheitsprüfung von: Rebecca
Geschrieben am: 22.08.2008 09:34:42

Hallo Erich,
recht herzlichen Dank.
Funktioniert hervorragend.
Ein schönes Wochenende wünscht
Rebecca


  

Betrifft: Danke für Rückmeldung - auch schönes WoEnde! (oT) von: Erich G.
Geschrieben am: 22.08.2008 09:50:34