Microsoft Excel

Herbers Excel/VBA-Archiv

Mittelwert wenn Eintrag

Betrifft: Mittelwert wenn Eintrag von: Dani
Geschrieben am: 14.08.2008 16:26:04

Hi Ihr!

Ich hab da mal ein kleines Problem:

Ich habe eine Exceltabelle in die nach und nach in jede Zeile Punkte von 1 bis 10 eingetragen werden. Am Ende werden diese dann summiert und immer der Durchschnitt gebildet. Wenn ich hier nun eine Vorlage mach und auch bereits die Summenfunktion eintrage, steht in der Gesamtspalte jeder Zeile immer Null und der Durchschnitt wird verfälscht!

Weiss jemand ob und wie ich das verhindern kann, etwa dass die Nullen nicht berücksichtigt werden?

Danke schon mal!
Dani

  

Betrifft: Mittelwert ohne 0 und ohne Leerzellen von: heikoS
Geschrieben am: 14.08.2008 16:32:45

Hallo Dani,

das geht so:

Tabelle2

 ABCDE
1129128,25
225 7 
353 8 
46  6 
5   0 
6     

Formeln der Tabelle
ZelleFormel
D1=SUMME(A1:C1)
E1{=MITTELWERT(WENN(D1:D10<>0;D1:D10))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Klappt´s?


Gruß Heiko


  

Betrifft: AW: Mittelwert ohne 0 und ohne Leerzellen von: Dani
Geschrieben am: 14.08.2008 16:34:29

Hey Hey

Vielen Dank!
Hast mir sehr geholfen!

Dani


  

Betrifft: Bitte, danke für Deine Rückmeldung! oT von: heikoS
Geschrieben am: 14.08.2008 16:41:21




 

Beiträge aus den Excel-Beispielen zum Thema "Mittelwert wenn Eintrag"