Liste per Formel kopieren mit Begrenzungsvorgabe

Bild

Betrifft: Liste per Formel kopieren mit Begrenzungsvorgabe
von: Joerschi
Geschrieben am: 05.10.2015 21:27:19

Hallo liebes Forum,
folgendes Problem möchte ich per Formel lösen (erst Skizze + Musterdatei, Beschreibung unten):
Userbild
https://www.herber.de/bbs/user/100608.xlsx
In B2:L2 ist eine Liste mit Zahlenwerten fix vorgegeben.
In C4 soll außerdem eine Zahl als Vorgabe angegeben werden.
In B6:L6 soll nun die Liste von links nach rechts wieder angezeigt werden mit folgenden Bedingungen:
A) Anzeige aller Zahlen von li nach re bis zu jener Zahl lt. Vorgabe, die am weitesten rechts steht
B) Falls in der Vorgabe eine Zahl angegeben ist, die es in der Liste nicht gibt, dann wird die komplette Liste von B6:C6 angezeigt.

Zum besseren Verständnis oben in Zeile 8 bis 12 in kursiv die richtigen Lösungen für verschiedene Vorgaben.
Hat jemand von Euch eine Idee?
Danke vorab und Liebe Grüße
Joerschi

Bild

Betrifft: AW: Liste per Formel kopieren mit Begrenzungsvorgabe
von: Sepp
Geschrieben am: 05.10.2015 21:56:04
Hallo Joerschi,
Tabelle1

 ABCDEFGHIJKL
1            
2Liste00212232132
3            
4Vorgabe größte Zahl: 1         
5            
6Liste neu:002122321  
7            
8Lösung bei Vorgabe=000         
9Lösung bei Vorgabe=1002122321  
10Lösung bei Vorgabe=200212232132
11Lösung bei Vorgabe=30021223213 
12Lösung bei Vorgabe=800212232132
13            

Formeln der Tabelle
ZelleFormel
B6=WENNFEHLER(INDEX($B$2:$L$2;;SPALTE(A1)/(AGGREGAT(14;6;SPALTE($A$1:$K$1)/(($B$2:$L$2=$C$4)+(NICHT(ISTZAHL(VERGLEICH($C$4;$B$2:$L$2;0))))); 1)>=SPALTE(A1))); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Sepp


Bild

Betrifft: AW: Liste per Formel kopieren mit Begrenzungsvorgabe
von: Joerschi
Geschrieben am: 05.10.2015 21:59:51
Danke Dir Sepp.
Ist dann doch um einiges komplexer als ich gehofft/gedacht hatte :-)
Liebe Grüße und nochmals Dank
Joerschi

Bild

Betrifft: Was heißt komplex, ...
von: Luc:-?
Geschrieben am: 05.10.2015 23:52:00
…Joerschi? ;-)
Es geht doch auch (wesentlich kürzer) mit einer simplen, index-basierten MatrixFml:
B6:L6: {=INDEX(B2:L2;1):INDEX(B2:L2;MAX(WENN(B2:L2=C4;SPALTE(A:K))))}
Und wenn die ErgebnisVektoren stets genauso lang wie die ZahlenListe sein sollen (ohne #NV), dann so:
B6:L6: {=WENNFEHLER(1^B2:L2-1+INDEX(B2:L2;1):INDEX(B2:L2;MAX(WENN(B2:L2=C4;SPALTE(A:K))));"")}
Gruß, Luc :-?

Besser informiert mit …

Bild

Betrifft: Noch etwas weniger 'komplex' so ...
von: Luc:-?
Geschrieben am: 06.10.2015 01:53:47
B6:L6: {=INDEX(B2:L2;1):INDEX(B2:L2;VERWEIS(C4;B2:L2;SPALTE(A:K)))} bzw so …
B6:L6: {=WENNFEHLER(1^B2:L2-1+INDEX(B2:L2;1):INDEX(B2:L2;VERWEIS(C4;B2:L2;SPALTE(A:K)));"")}
Luc :-?

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Liste per Formel kopieren mit Begrenzungsvorgabe"