Microsoft Excel

Herbers Excel/VBA-Archiv

Minimum ohne Null | Herbers Excel-Forum


Betrifft: Minimum ohne Null von: Camilla
Geschrieben am: 16.01.2012 17:02:59

Hallo

in der obersten linken Zelle in untenstehender Tabelle möchte ich den kleinsten Wert ausweisen, der sich ergibt, wenn die Zahlen in den darunterliegenden Zeilen jeweils multipliziert werden:

0,0
1 1,0
1 0,5
2 1,0
0 1,0
4 1,0

Bei Verwendung von =MIN(A2 * B2; A3 * B3; A4 * B4; A5 * B5; A6 * B6) wird "0" ausgewiesen; die "0" soll jedoch ausgenommen werden und als geringster Wert soll 0,5 ausgewiesen werden; wie kann dies erreicht werden, ohne dass ich eine zusätzliche Spalte einfüge, in der sich das Produkt errechnet und ausgewiesen wird?

  

Betrifft: AW: Minimum ohne Null von: Walter
Geschrieben am: 16.01.2012 17:11:36

Hallo
Möchten Sie die Nullwerte ignorieren arbeiten Sie mit nachstehender Matrixformel



{=MITTELWERT(WENN(B1:D1;B1:D1))}


  

Betrifft: AW: Minimum ohne Null von: Camilla
Geschrieben am: 16.01.2012 17:18:45

...ergibt bei mir: #Div/0...


  

Betrifft: {=MIN((WENN(A2:A100<>0;A2:A100)))} von: Walter
Geschrieben am: 16.01.2012 17:23:13

{=MIN((WENN(A2:A100<>0;A2:A100)))}


  

Betrifft: AW: {=MIN((WENN(A2:A100<>0;A2:A100)))} von: Camilla
Geschrieben am: 16.01.2012 17:32:36

...wenn ich diese Formel verwende,ergibt sich als Miinimum "1" und nicht "0,5" wie unter Berücksichtigung des Faktors 0,5 in Zeile 3 richtig wäre....


  

Betrifft: AW: {=MIN((WENN(A2:A100<>0;A2:A100)))} von: Walter
Geschrieben am: 16.01.2012 17:40:57

.. bei mir kommt o,5 zur Anzeige
Format Zelle eine Kommastelle 0,0


PS
Wie steht mit Anredeform?

Gruß
Walter


  

Betrifft: AW: Minimum ohne Null von: Camilla
Geschrieben am: 16.01.2012 17:50:59

...selbst mit zwei Dezimalstellen, bleibt's bei "1"...


  

Betrifft: AW: Minimum ohne Null von: Erich G.
Geschrieben am: 16.01.2012 19:24:31

Hi Camilla,
probiers mal so:

 AB
10,5 
211,00
310,50
421,00
501,00
641,00
7  

Formeln der Tabelle
ZelleFormel
A1{=MIN(WENN(A2:A98<>0;A2:A98*B2:B98))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Was sollte hier MITTELWERT bringen?
Und warum kam in den bisherigen Formeln die Spalte B gar nicht vor? :-(

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: Minimum ohne Null von: Camilla
Geschrieben am: 17.01.2012 09:20:43

Hey, super!...hat hingehauen! Ganz herzlichen Dank und einen tollen Tag!

c.


Beiträge aus den Excel-Beispielen zum Thema "Minimum ohne Null"