Microsoft Excel

Herbers Excel/VBA-Archiv

Werte aus zelle

Betrifft: Werte aus zelle von: TIM
Geschrieben am: 20.10.2020 06:36:15

Hallo zusammen
Wir haben eine Liste bekommen.
Und zelle schaut es so aus

A2 = 2DGT, 1GO
A3= 2ber, 1GO
A4 = 4ber,3KR, 5BOR

Kann man nur die Werte in der Zelle suchen und zählen

A2 WÄRE 3
A3 WÄRE 3
A4 WÄRE 12

Ich hoffe ihr findet einen Lösung. Danke

Betrifft: GLÄ-WEX-WDH
von: lupo1
Geschrieben am: 20.10.2020 08:48:39

B2: =SUMMENPRODUKT(--LINKS(GLÄTTEN(TEIL(WECHSELN(A2&WIEDERHOLEN(",0";26);",";WIEDERHOLEN(" ";199));SPALTE(A:Z)*199-198;199))))

für einstellige Summanden gemäß Beispiel.

Betrifft: Alternativ per...
von: Case
Geschrieben am: 20.10.2020 09:15:40

Hallo, :-)

...RegExp: ;-)

Beispieldatei...

Servus
Case

Betrifft: AW: Alternativ per...
von: TIM
Geschrieben am: 20.10.2020 09:17:35

Das habe ich noch nie gesehen .
Cool

Betrifft: AW: Alternativ per...
von: Günther
Geschrieben am: 20.10.2020 10:06:13

Moin,
das gilt wahrscheinlich auch für Power Query (in deiner Version als Add-In). :-)
Das wäre bei großen Datenmengen und/oder bei VBA-Verbot interessant.
 
Gruß
Günther  |  mein Excel-Blog

Betrifft: Alternativ per Fml m.VBA-basierten UDFs, ...
von: Luc:?
Geschrieben am: 20.10.2020 15:03:37

…die zT schon seit 15 Jahren im Archiv zu finden sind, Tim:
Var1: =SUMME(VSplit(MaskOn(A2;"num");;1))
Var2: =TxEval(WECHSELN(MaskOn(A2;"num");" ";"+"))
UDF-Links:
MaskOn (Vs2.1) https://www.herber.de/forum/archiv/1344to1348/1344962_Initialen_bei_Doppelnamen.html#1345181
TxEval (Vs1.0) https://www.herber.de/forum/archiv/1476to1480/1476498_Projektplan.html#1477400
VSplit (Vs1.1) https://www.herber.de/bbs/user/99024.xlsm (BspDatei m.UDFs)
Gruß, Luc :-?
„Die universelle Befähigung zur Unfähigkeit macht jede menschliche Leistung zu einem unglaublichen Wunder.“ Stapps ironisches Paradoxon