Microsoft Excel

Herbers Excel/VBA-Archiv

Daten aus anderer Tabelle übernehmen

Betrifft: Daten aus anderer Tabelle übernehmen von: Thomas
Geschrieben am: 20.08.2004 14:55:19

Hallo Zusammen,
im Archiv bin ich leider nicht fündig geworden! Folgendes Problem:
In Tabelle "Test" habe ich Namen (Spalte A), Telefonnummer (Spalte B), Beruf (Spalte C), Abteilung (Spalte D)!
Wenn ich eine zweite Tabelle öffne und in Spalte A den Namen "Meier" eingebe, soll Excel mir die dazugehörige Telefonnummer, Beruf, Abteilung etc. aus Tabelle "Test" geben. Ist dies ohne große VBA-Programmierung möglich?
Ich zähle auf Euch, vielen Dank und Gruß Thomas

  


Betrifft: sverweis() von: ransi
Geschrieben am: 20.08.2004 15:20:55

hallo thomas

schau dir mal sverweis() an.
macht genau das was du willst.

gruß ransi


  


Betrifft: AW: sverweis() von: Thomas
Geschrieben am: 20.08.2004 15:46:14

Schon, aber bei meiner Formel (s.u.) kommt immer die Fehlermeldung #Bezug!

=SVERWEIS(A5;[TEST_Adressenliste.xls]Tabelle1!$A$5:$A$14;[TEST_Adressenliste.xls]Tabelle1!$B$5:$B$14;FALSCH)

In "A5" steht der Name "Meier" als Suchkriterium
Matrix = Informationstabelle ist die "TEST_Adressenliste" der Name ebenfalls in Spalte A
Spaltenindex = in der Tabelle "TEST_Adressenliste" in Spalte B
Bereich_Verweis = FALSCH!!!!

Aber was bitte mache ich falsch in der Formel


  


Betrifft: AW: sverweis() von: ransi
Geschrieben am: 20.08.2004 16:02:54

hallo
versuch mal so:

=SVERWEIS(A5;[TEST_Adressenliste.xls]Tabelle1!$A:$D;2;FALSCH)
sollte die telefonnummer rauskommen.
wenn nicht, lad doch mal 2 beispieldatein hoch.
ransi


  


Betrifft: AW: sverweis() von: ransi
Geschrieben am: 20.08.2004 16:10:41

hallo
ich versuch das zu erklären.
ich glaub so ist es in deinen tabellen:
In "A5" steht der Name "Meier" als Suchkriterium
Matrix = Informationstabelle ist die "TEST_Adressenliste", also matrix A:D
Spaltenindex = in der Tabelle "TEST_Adressenliste". in 2 spalten weiter als dein suchbegriff stehn die telefonnummern.
Bereich_Verweis = FALSCH!!!!

ransi


  


Betrifft: AW: sverweis() von: Thomas
Geschrieben am: 20.08.2004 16:11:24

Hallo Ransi,

super vielen Dank hat geklappt. Wobei ich den Grund rein logisch überhaupt nicht verstehe!!! Warum die Zahl "2" vor der Bedingung "FALSCH"? Was hat diese Bedingung für eine Bedeutung?
Nochmals vielen Dank für deine Hilfe!!!
Viele Grüße Thomas


  


Betrifft: AW: sverweis() von: ransi
Geschrieben am: 20.08.2004 16:17:53

hallo thomas

der wert der 2 spalten weiter rechts von deinem suchbegriff in deiner suchmatrix steht.(telefonnummern)
der beruf steht in der dritten. also muss da eine 3 rein.
is eigentlich ganz einfach wenn man das system erstmal verstanden hat.

freut mich wenn ich helfen konnte
ransi


  


Betrifft: AW: Daten aus anderer Tabelle übernehmen von: harry
Geschrieben am: 20.08.2004 16:04:04

hi,
hier wäre eine vba-lösung. hab allerdings erst zu spät gesehen, dass du off97 hast, weiß daher nicht,ob es bei dir funkt.
https://www.herber.de/bbs/user/9880.xls

liebe grüße,
harry


 

Beiträge aus den Excel-Beispielen zum Thema "Daten aus anderer Tabelle übernehmen"