Daten in andere Tabelle bringen



Excel-Version: 97
  

Re: Daten in andere Tabelle bringen

von: Gerd
Geschrieben am: 15.04.2002 - 20:41:42


Hallo Nora

versuche es mit folgender Formel
=WENN(ISTFEHLER(SVERWEIS(C1;Tabelle1!A:B;2;0));0;SVERWEIS(C1;Tabelle1!A:B;2;0))
diese schreibst Du in die Tabelle2 in Spalte D1

MfG
Gerd

  

Re: Daten in andere Tabelle bringen

von: Gerd
Geschrieben am: 15.04.2002 - 20:41:43


Hallo Nora

versuche es mit folgender Formel
=WENN(ISTFEHLER(SVERWEIS(C1;Tabelle1!A:B;2;0));0;SVERWEIS(C1;Tabelle1!A:B;2;0))
diese schreibst Du in die Tabelle2 in Spalte D1

MfG
Gerd

  

Geht so nicht-Daten in andere Tabelle bringen

von: Nora
Geschrieben am: 16.04.2002 - 11:40:35


Das geht zwar schon, aber nicht in meinem Fall. Ich kann in die zweite Tabelle keine Befehle eingeben, deswegen muss ich die Daten ÜBERGEBEN. Ich kann sie nicht von Tabelle2 holen.
Das ist ja das Problem.

  

Re: Geht so nicht-Daten in andere Tabelle bringen

von: Giovanni
Geschrieben am: 16.04.2002 - 13:20:37


'Erzeuge Modul1
'Kopiere Code in Modul1
'Speichere die Datei
'Lass auto_open laufen
'Tabelle1 und Tabelle2 müßen existieren
'Datenfluß in Spalten mit Daten müß durchgehend sein.(Keine leere Zellen)

Option Explicit
Dim wert1
Dim wert2

Sub auto_open()
Call start
End Sub

Private Sub start()
ActiveSheet.Range("A1").Select

Do
wert1 = CStr(ActiveCell.Value)
wert2 = ActiveCell.Offset(0, 1).Value

Call Prüfen

ActiveCell.Offset(1, 0).Select

Loop While ActiveCell.Value <> ""

End Sub

Private Sub Prüfen()
Sheets("Tabelle2").Select

Range("A1").Select

Do
If UCase(CStr(ActiveCell.Value)) = UCase(wert1) Then
ActiveCell.Offset(0, 1).Value = wert2
Exit Do
End If

ActiveCell.Offset(1, 0).Select
Loop While ActiveCell.Value <> ""

Sheets("Tabelle1").Select

End Sub

  

Re: Geht so nicht-Daten in andere Tabelle bringen

von: Nora
Geschrieben am: 16.04.2002 - 15:52:38


Ich hab das versucht, aber bei:

Private Sub Prüfen()
Sheets("G:\EK\Bedarfsbündelung\Quarze\[Preise CM Quarze.xls]Preise RFCrystal").Select

bringt der mir eine Fhlermeldung:
Index außerhalb des gültigen Bereichs.

Liegt das daran, dass ich keine andere Datei nehmen kann?
Meine Tabelle1 hat den Pfad: G:\EK\....[Masterdatei Quarze.xls]Quarze

nach unten

Betrifft: Daten in andere Tabelle bringen
von: Nora
Geschrieben am: 15.04.2002 - 15:11:30

Hallo ihr fleißigen Helfer!

Ich habe zwei Dateien:

A______B
111____25
112____30
113____23
127____25


und

C______D
110____Übertrag-hier keiner
111____Übertrag-hier:25
112____Übertrag-hier:30
113____Übertrag-hier:23
114____Übertrag-hier:keiner
127____Übertrag-hier:25


Wie gesagt, ich habe zwei Tabellen-unterschiedliche Dateien.

Es muss überprüft werden, ob der Wert/String aus der 1.Tabelle Spalte A, in der 2.Tabelle Spalte C vorkommt. Ist das der Fall, dann muss der zugehörige Wert aus Spalte B der 1.Tabelle, in die Spalte D der 2.Tabelle übertragen werden.

Meine Tabellen sind relativ groß. Es muss also sicher irgendeine Abfrage sein, die von Zeile 2 bis Zeile 500 (der 1.Tabelle)läuft.

Das muss doch mit Hilfe von IF, FOR, DO, usw. Anweisungen zu realisieren sein.

Wäre über eine Lösung sehr dankbar.

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Daten in andere Tabelle bringen"