Werte aus unterschiedliche tabellen

Bild

Betrifft: Werte aus unterschiedliche tabellen
von: Lino
Geschrieben am: 20.05.2015 15:15:18

Hallo an alle
MEIN Problem:
Ich habe eine Zentrale Tabelle wo ich mit der Eingabe der Artikel NR. den Preis aus 3 Tabellen hole. Suche erst in Tabelle1 wenn Artikel vorhanden dann übernehme den Preis wenn nicht dann gehe in Tabelle2 .... dann Tabelle3. Das Funktioniert.
Was ich nun gerne hätte, wäre zu sehen aus welcher Tabelle der Preis übernommen wurde. Ich dachte in Form einer Farbigen schrift oder Zellenfarbe zb. Tabelle1 "rot", Tabelle2 "grün", usw.
oder auch eine Zusätzliche Spalte wo steht aus welcher Tabelle der Wert übernommen wurde.
Ist es möglich??
Für hilfe wäre ich sehr dankbar.
Grüsse Lino

Bild

Betrifft: Ja.
von: Michael
Geschrieben am: 20.05.2015 15:36:58
Hi Lino,
indem Du an geeigneter Stelle, nämlich da, wo Du den Preis in die Zelle schreibst, die Eigenschaft interior.color setzt, z.B. so:
Range("C1").Interior.Color = vbRed
vbRed ist das Standardrot, das gibt es in gelb, grün usw. auch.
Schöne Grüße,
Michael

Bild

Betrifft: AW: Ja.
von: Lino
Geschrieben am: 21.05.2015 09:39:48
Hallo Michael
Hallo Matthias
Danke für euere Antworten.
Ich benutzte nachfolgenede Formeln:
=WENN(NICHT(ISTFEHLER(SVERWEIS(A3;Infosätze2015!B:L;10;0)));
SVERWEIS(A3;Infosätze2015!B:L;10;0);
WENN(NICHT(ISTFEHLER(SVERWEIS(A3;Photovoltaik!E:F;2;0)));
SVERWEIS(A3;Photovoltaik!E:F;2;0);
WENN(NICHT(ISTFEHLER(SVERWEIS(A3;Infosätze_SAP_2015!A:J;9;0)));
SVERWEIS(A3;Infosätze_SAP_2015!A:J;9;0);"!!!")))
Grüsse
Lino

Bild

Betrifft: AW: Ja.
von: Michael
Geschrieben am: 21.05.2015 13:39:42
Hi Lino,
vielleicht hat Matthias ja einen besseren Vorschlag, aber mir fällt nur die Lösung über einige Hilfsspalten ein.
In Deiner Formel führst Du ja jeden SVERWEIS zweimal pro Tabelle aus; wenn Du den SVerweis pro Tabelle in eine Spalte "rechts" setzt, mußt Du zur Wertezuweisung nur diese 3 Zellen/Spalten auswerten.
Je nachdem, welche der drei Spalten keinen Fehler anzeigt, müßte man dann mit einer bedingten Formatierung arbeiten können. Evtl. über eine weitere Hilfsspalte, damit die Formel für die bedingte Formatierung nicht zu unübersichtlich wird.
Hier mal ne Datei, damit Du weißt, was ich meine: https://www.herber.de/bbs/user/97756.xls
Schöne Grüße,
Michael

Bild

Betrifft: Ich frage mich nur gerade ...
von: Matthias L
Geschrieben am: 21.05.2015 18:59:57
Hallo
Wenn man mit Formeln ermittelt aus welchem Tabellenlatt man den Wert "zieht"
kann man ja eigentlich die gleiche Formel für die bedingte Formatierung benutzen.
Zum Nachbauen von Linos Datei hab ich keine Lust.
Er/Sie hätte ja auch die Datei hochladen können.
Gruß Matthias

Bild

Betrifft: AW: Ich frage mich nur gerade ...
von: Michael
Geschrieben am: 22.05.2015 16:38:00
Hi Matthias,
tja, mit ihren Dateien sind viele Leute recht zurückhaltend ...
... und mit Rückmeldungen auch.
Aber lassen wir uns die Laune nicht verderben,
schöne Grüße,
Michael

Bild

Betrifft: AW: Werte aus unterschiedliche tabellen
von: Matthias L
Geschrieben am: 20.05.2015 16:35:39
Hallo
Dazu müsste man erst mal wissen, wie Du den Preis ermittelst!
Zitat:
Suche erst in Tabelle1 wenn Artikel vorhanden dann übernehme den Preis wenn nicht dann gehe in Tabelle2 .... dann Tabelle3. Das Funktioniert.
Wenn das funktioniert, warum zeigst Du denn nicht wie Du den Preis übernimmst
Das geht nämlich mit VBA aber auch mit Formel.
Mit VBA ist das überhaupt kein Problem den Blattnamen auszuwerten
Mit Formel, würde ich =Zelle(Infotyp;Bezug) benutzen.
Dort kannst Du dann den Blattnamen nach dem "]" extrahieren
Mit =ZELLE("Dateiname";A1) steht dann rechts der Registerblattname
Gruß Matthias

Bild

Betrifft: AW: Werte aus unterschiedliche tabellen
von: Lino
Geschrieben am: 26.05.2015 13:52:51
Hallo an Alle
Sorry war weg.
Anbei meine Tabelle wie ich sie heute benutzte. Wollte nichts verheimlichen, denn ich habe auch den nutzten.
https://www.herber.de/bbs/user/97850.xlsx
Grüsse
Lino

Bild

Betrifft: AW: Werte aus unterschiedliche tabellen
von: Matthias L
Geschrieben am: 26.05.2015 16:20:34
Hallo
Benutz doch die gleiche Formel nur eben anders ;-)

 ABCDEF
3691FCR 18/60 6kW Heizfl. Infosätze2015650,00CHF
4752SRT 1 Sicherheitsventil SH30/SH150 Infosätze_SAP_201558,04EUR
5273590Wechselrichter SMA Sunny Boy 3000 TLST 1-Phasig Photovoltaik1.600,00!!!
6695FCR 28/180 E 18kW Heizfl. Infosätze2015950,00CHF


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
 ABCD
3691FCR 18/60 6kW Heizfl. Infosätze2015
4752SRT 1 Sicherheitsventil SH30/SH150 Infosätze_SAP_2015
5273590Wechselrichter SMA Sunny Boy 3000 TLST 1-Phasig Photovoltaik
6695FCR 28/180 E 18kW Heizfl. Infosätze2015

Formeln der Tabelle
ZelleFormel
D3=WENN(NICHT(ISTFEHLER(SVERWEIS(A3;Infosätze2015!B:L;10;0)));
"Infosätze2015";
WENN(NICHT(ISTFEHLER(SVERWEIS(A3;Photovoltaik!E:F;2;0)));
"Photovoltaik";
WENN(NICHT(ISTFEHLER(SVERWEIS(A3;Infosätze_SAP_2015!A:I;9;0)));
"Infosätze_SAP_2015";"!!!")))
D4=WENN(NICHT(ISTFEHLER(SVERWEIS(A4;Infosätze2015!B:L;10;0)));
"Infosätze2015";
WENN(NICHT(ISTFEHLER(SVERWEIS(A4;Photovoltaik!E:F;2;0)));
"Photovoltaik";
WENN(NICHT(ISTFEHLER(SVERWEIS(A4;Infosätze_SAP_2015!A:I;9;0)));
"Infosätze_SAP_2015";"!!!")))
D5=WENN(NICHT(ISTFEHLER(SVERWEIS(A5;Infosätze2015!B:L;10;0)));
"Infosätze2015";
WENN(NICHT(ISTFEHLER(SVERWEIS(A5;Photovoltaik!E:F;2;0)));
"Photovoltaik";
WENN(NICHT(ISTFEHLER(SVERWEIS(A5;Infosätze_SAP_2015!A:I;9;0)));
"Infosätze_SAP_2015";"!!!")))
D6=WENN(NICHT(ISTFEHLER(SVERWEIS(A6;Infosätze2015!B:L;10;0)));
"Infosätze2015";
WENN(NICHT(ISTFEHLER(SVERWEIS(A6;Photovoltaik!E:F;2;0)));
"Photovoltaik";
WENN(NICHT(ISTFEHLER(SVERWEIS(A6;Infosätze_SAP_2015!A:I;9;0)));
"Infosätze_SAP_2015";"!!!")))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Werte aus unterschiedliche tabellen"