Werte aus Tabelle zurückgeben

Bild

Betrifft: Werte aus Tabelle zurückgeben
von: Michael Engelhardt
Geschrieben am: 03.12.2003 09:11:56

Hallo Zusammen,
ich habe folgendes Problem:

Eine Tabelle mit 4 Spalten und X Zeilen in Spalte A steht ein Text in den Spalten B, C und D stehen Werte.

In den Zeilen der Spalte A steht immer ein Text in den anderen Zeilen der Spalten kommen auch manchmal keine Werte vor.
Ich möchte nun den Text der Spalte A in in eine andere Spalte übernehmen, aber nur wenn Bx, Cx und Dx größer Null sind oder mindestes 1 Wert größer Null ist.

Ergebnis sollte das sein, dass in der neuen Spalte immer nur der Text von Ax bei dem mind. 1 Wert von Bx Cx oder Dx größer als Null ist. Also ohne die ganzen Leerzeilen.

Ich vermute das geht mit einer Matrix/Array-Formel. Aber leider habe ich von diesen Formeln nicht so viel Ahnung. Wer kann mir helfen

Gruß
Michael

Bild


Betrifft: AW: Werte aus Tabelle zurückgeben
von: Michael Engelhardt
Geschrieben am: 03.12.2003 10:01:24

Hier ein das Beispiel

https://www.herber.de/bbs/user/2285.xls


Bild


Betrifft: AW: Werte aus Tabelle zurückgeben
von: Martin Beck
Geschrieben am: 03.12.2003 10:41:16

Hallo Michael,

ein Ansatz ohne MAtrixformeln:

1. Schreibe in die erste Zeile der Ergebnisspalte folgende Formel und kopiere sie nach unten

=WENN(NICHT(UND(ISTLEER(B1);ISTLEER(C1);ISTLEER(D1)));A1;"")

2. Markiere die Ergebnisspalte und wandle die Formeln in Werte um.

3. Markiere die Ergebnisspalte und gib ein BEARBEITEN-GEHEZU-INHALTE, wähle die Option KONSTANTEN und entferne alle Häkchen außer bei "Text".

4. BEARBEITEN-ZELLEN LÖSCHEN und dann die Option "Zellen nach oben verschieben"

Gruß
Martin Beck


Bild


Betrifft: AW: Werte aus Tabelle zurückgeben
von: Michael Engelhardt
Geschrieben am: 03.12.2003 10:59:49

Hallo Martin,

vielen Dank erstmal. Aber das Problem ist das der Bereich Bx:Dx auf eine OLAP-Datenbank zurückgreift und damit variabel ist, was die Werte betrifft.

Ich bräuchte eine Lösung, die flexibel den Text aus Spalte A zurück gibt jenachdem ob im Bereich Bx:Dx mind. 1 Zelle einen Wert hat der größer Null ist.

Momentan habe ich eine weitere Spalte mit der Formel kgrösste(B1:D1);1) eingefügt. Theoretisch wäre mein Problem gelöst, wenn man dem SVERWEIS als Suchkriterium sagen könnte "Größer Null". Ich weis leider nicht, wie ich das hinbekommen soll.

Gruß
Michael


Bild


Betrifft: AW: Werte aus Tabelle zurückgeben
von: Martin Beck
Geschrieben am: 03.12.2003 11:12:25

Hallo Michael,

Du kannst ja die WENN-Formel bis zur letzten Zeile (65536) nach unten kopieren. Ich kann mich jetzt nicht weiter drum kümmern, da ich gleich weg muß. Noch ein Tip: Schau Dich mal auf www.excelformeln.de um.

Gruß
Martin Beck


Bild

Beiträge aus den Excel-Beispielen zum Thema " Werte aus Tabelle zurückgeben"