daten aus 2 zellen in eine

Bild

Betrifft: daten aus 2 zellen in eine von: Christian
Geschrieben am: 21.02.2005 17:42:48

Guten Tag Excel-Profis,

wie kann Ecxel die Namen (auch gleiche)aus Spalte "A" erkennen, sortieren und die dazugehörigen Nummern aus Spalte "B" mit den Namen verknüpfen und einmal je Name in Spalte "C" schreiben?

Spalte A / Spalte B
Name Nummer
Meier 1
Meier 4
Meier 6
Schulze 2
Schulze 4
Schulze 5
Gast 45
Gast 34
Gast 23
Gast 12
Meier 9
Schulze 3

Ergebnis in Spalte "C"

Gast 45-34-23-12
Meier 1-4-6-9
Schulze 2-4-5-3

Habe eine Excel-Datei zugefühgtund hoffe auf eure Hilfe.
Vielen Dank
Christian

Bild


Betrifft: AW: daten aus 2 zellen in eine von: Reinhard
Geschrieben am: 21.02.2005 18:26:49

Hi christian,
schau mal bei http://www.excelformeln.de
ich mein da wäre eine Lösung dafür.
Wenn du nichts findest melde dich hier nochmal.
Bin jezt für ne Stunde weg, daher jetzt keine Zeit.
Gruß
Reinhard


Bild


Betrifft: AW: daten aus 2 zellen in eine von: Reinhard
Geschrieben am: 21.02.2005 22:32:07

Hi Christian,
aus: http://www.excelformeln.de/formeln.html?welcher=164
Beachte dort die Hinweise auf doppelte Einträge in A.
Beacte auch, die Formeln in D sind Matrixformeln, werden hier nur nicht angezeigt.
Tabellenblattname: Tabelle1
       A    | B  | C  |    D    | E  | F  | G  | H |        I        | 
 1|   meier |  1 |  1 |   meier |  1 |  4 |  6 | 2 |   meier 1 4 6 2 | 
 2|         |  4 |  5 | Schulze |  4 |  5 | 45 |   | Schulze 4 5 45  | 
 3|         |  6 |  8 |    Gast | 34 | 23 | 12 |   |  Gast 34 23 12  | 
 4|         |  2 | 11 |   Meyer |  9 |    |    |   |      Meyer 9    | 
 5| Schulze |  4 | 12 |   kunze |  3 |    |    |   |      kunze 3    | 
 6|         |  5 | 13 |         |    |    |    |   |                 | 
 7|         | 45 | 13 |         |    |    |    |   |                 | 
 8|    Gast | 34 | 13 |         |    |    |    |   |                 | 
 9|         | 23 | 13 |         |    |    |    |   |                 | 
10|         | 12 | 13 |         |    |    |    |   |                 | 
11|   Meyer |  9 | 13 |         |    |    |    |   |                 | 
12|   kunze |  3 | 13 |         |    |    |    |   |                 | 
Benutzte Formeln:
C1:  =WENN(D1="";ANZAHL2(B:B)+1;VERGLEICH(D1;A:A;0))
C2:  =WENN(D2="";ANZAHL2(B:B)+1;VERGLEICH(D2;A:A;0))
C3:  =WENN(D3="";ANZAHL2(B:B)+1;VERGLEICH(D3;A:A;0))
C4:  =WENN(D4="";ANZAHL2(B:B)+1;VERGLEICH(D4;A:A;0))
C5:  =WENN(D5="";ANZAHL2(B:B)+1;VERGLEICH(D5;A:A;0))
C6:  =WENN(D6="";ANZAHL2(B:B)+1;VERGLEICH(D6;A:A;0))
C7:  =WENN(D7="";ANZAHL2(B:B)+1;VERGLEICH(D7;A:A;0))
C8:  =WENN(D8="";ANZAHL2(B:B)+1;VERGLEICH(D8;A:A;0))
C9:  =WENN(D9="";ANZAHL2(B:B)+1;VERGLEICH(D9;A:A;0))
C10:  =WENN(D10="";ANZAHL2(B:B)+1;VERGLEICH(D10;A:A;0))
C11:  =WENN(D11="";ANZAHL2(B:B)+1;VERGLEICH(D11;A:A;0))
C12:  =WENN(D12="";ANZAHL2(B:B)+1;VERGLEICH(D12;A:A;0))
D1:  =WENN(ZEILE()>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$1000<>0;ZEILE(A$1:A$1000));ZEILE())))
D2:  =WENN(ZEILE()>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$1000<>0;ZEILE(A$1:A$1000));ZEILE())))
D3:  =WENN(ZEILE()>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$1000<>0;ZEILE(A$1:A$1000));ZEILE())))
D4:  =WENN(ZEILE()>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$1000<>0;ZEILE(A$1:A$1000));ZEILE())))
D5:  =WENN(ZEILE()>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$1000<>0;ZEILE(A$1:A$1000));ZEILE())))
D6:  =WENN(ZEILE()>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$1000<>0;ZEILE(A$1:A$1000));ZEILE())))
D7:  =WENN(ZEILE()>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$1000<>0;ZEILE(A$1:A$1000));ZEILE())))
D8:  =WENN(ZEILE()>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$1000<>0;ZEILE(A$1:A$1000));ZEILE())))
D9:  =WENN(ZEILE()>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$1000<>0;ZEILE(A$1:A$1000));ZEILE())))
D10:  =WENN(ZEILE()>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$1000<>0;ZEILE(A$1:A$1000));ZEILE())))
D11:  =WENN(ZEILE()>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$1000<>0;ZEILE(A$1:A$1000));ZEILE())))
D12:  =WENN(ZEILE()>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$1000<>0;ZEILE(A$1:A$1000));ZEILE())))
E1:  =WENN(SPALTE()-4>$C2-$C1;"";INDEX($B:$B;SPALTE()-4+$C1-1))
E2:  =WENN(SPALTE()-4>$C3-$C2;"";INDEX($B:$B;SPALTE()-4+$C2-1))
E3:  =WENN(SPALTE()-4>$C4-$C3;"";INDEX($B:$B;SPALTE()-4+$C3-1))
E4:  =WENN(SPALTE()-4>$C5-$C4;"";INDEX($B:$B;SPALTE()-4+$C4-1))
E5:  =WENN(SPALTE()-4>$C6-$C5;"";INDEX($B:$B;SPALTE()-4+$C5-1))
F1:  =WENN(SPALTE()-4>$C2-$C1;"";INDEX($B:$B;SPALTE()-4+$C1-1))
F2:  =WENN(SPALTE()-4>$C3-$C2;"";INDEX($B:$B;SPALTE()-4+$C2-1))
F3:  =WENN(SPALTE()-4>$C4-$C3;"";INDEX($B:$B;SPALTE()-4+$C3-1))
F4:  =WENN(SPALTE()-4>$C5-$C4;"";INDEX($B:$B;SPALTE()-4+$C4-1))
F5:  =WENN(SPALTE()-4>$C6-$C5;"";INDEX($B:$B;SPALTE()-4+$C5-1))
G1:  =WENN(SPALTE()-4>$C2-$C1;"";INDEX($B:$B;SPALTE()-4+$C1-1))
G2:  =WENN(SPALTE()-4>$C3-$C2;"";INDEX($B:$B;SPALTE()-4+$C2-1))
G3:  =WENN(SPALTE()-4>$C4-$C3;"";INDEX($B:$B;SPALTE()-4+$C3-1))
G4:  =WENN(SPALTE()-4>$C5-$C4;"";INDEX($B:$B;SPALTE()-4+$C4-1))
G5:  =WENN(SPALTE()-4>$C6-$C5;"";INDEX($B:$B;SPALTE()-4+$C5-1))
H1:  =WENN(SPALTE()-4>$C2-$C1;"";INDEX($B:$B;SPALTE()-4+$C1-1))
H2:  =WENN(SPALTE()-4>$C3-$C2;"";INDEX($B:$B;SPALTE()-4+$C2-1))
H3:  =WENN(SPALTE()-4>$C4-$C3;"";INDEX($B:$B;SPALTE()-4+$C3-1))
H4:  =WENN(SPALTE()-4>$C5-$C4;"";INDEX($B:$B;SPALTE()-4+$C4-1))
H5:  =WENN(SPALTE()-4>$C6-$C5;"";INDEX($B:$B;SPALTE()-4+$C5-1))
I1:  =D1&" "&E1&" "&F1&" "&G1&" "&H1
I2:  =D2&" "&E2&" "&F2&" "&G2&" "&H2
I3:  =D3&" "&E3&" "&F3&" "&G3&" "&H3
I4:  =D4&" "&E4&" "&F4&" "&G4&" "&H4
I5:  =D5&" "&E5&" "&F5&" "&G5&" "&H5
Gruß
Reinhard
Tabelle wurde eingefügt mit Code von https://www.herber.de/forum/technik/messages/1226.html 



Bild


Betrifft: AW: daten aus 2 zellen in eine von: Christian
Geschrieben am: 23.02.2005 17:05:13

Danke Reinhard
war unterwegs und habe jetzt erst die Formel gesehen,

leider ist meine Datei ist sehr lang (Beispiel war nur ein Ausszg) und für mehr als 30.000 zeilen diese Formeln zu hinterlegen ist, so denke ich nicht möglich. Gibt es eine Lösung über makros, kenne mich kaum aus habe aber Unterstützung.
Wäre es möglich über eine Schleife die Nummern in EINE zelle zu packen, getrennt duch ","? Wie gesagt es können auch 40 oder 50 werden... Habe über Pivot die Zahlen zugeordnet und komme nicht weiter

Vielen Dank für die Hife und eine evt. Lösung für mein großes Problem

Christian


Bild


Betrifft: AW: daten aus mehreren zellen in eine von: Christian
Geschrieben am: 23.02.2005 17:22:02

Danke Reinhard
war unterwegs und habe jetzt erst die Formel gesehen,

leider ist meine Datei ist sehr lang (Beispiel war nur ein Ausszg) und für mehr als 30.000 zeilen diese Formeln zu hinterlegen ist, so denke ich nicht möglich. Gibt es eine Lösung über makros, kenne mich kaum aus habe aber Unterstützung.
Wäre es möglich über eine Schleife die Nummern in EINE zelle zu packen, getrennt duch ","? Wie gesagt es können auch 40 oder 50 werden... Habe über Pivot die Zahlen zugeordnet und komme nicht weiter

Vielen Dank für die Hife und eine evt. Lösung für mein großes Problem

Christian


 Bild

Beiträge aus den Excel-Beispielen zum Thema "daten aus 2 zellen in eine"