Microsoft Excel

Herbers Excel/VBA-Archiv

Werte aus Zelle in Spalten aufteilen

Betrifft: Werte aus Zelle in Spalten aufteilen von: Patrick
Geschrieben am: 17.09.2020 13:06:22

Hi zusammen,


ich habe jetzt schon viel gesucht und bin noch nicht zu 100% zufrieden mit meinem Ergebnis.


In Zelle X4 werden Werte aus einer externen Liste eingelesen und diese möchte ich auf benachbarte Spalten aufteilen, um sie dann Summieren zu können. VBA darf ich aus Firmengründen nicht verwenden, also muss alles über Formeln gehen.

Die Spalte sieht zum Beispiel so aus:


24,6 24,6 24,6 20,4 20,4 19,8 5,8 14,5


Ich hätte gerne jeden Wert (mal ein Kommawert, mal nicht) in die Spalten daneben aufgeteilt. Mit Text in Spalten funktioniert das nicht, weil die Werte ein Formelergebnis sind.


Ich habs jetzt für mich so gelöst:


=WENNFEHLER(GLÄTTEN(TEIL(WECHSELN($X4;";";WIEDERHOLEN(" ";999));SPALTE(B2)*999-998;999));0)


Leider kann ich dann die Werte aber nicht summieren, da bei leeren Spalten dann in der Summenformel immer 0 rauskommt und wenn ich mit + summiere, ein #WERT.


Habt ihr da da eine tolle Lösung parat?


Danke!


LG Patrick

Betrifft: GLÄ-WEX-WDH
von: lupo1
Geschrieben am: 17.09.2020 13:30:57

... kommt übrigens von mir.

Auflistung:
=
WENNFEHLER(--GLÄTTEN(TEIL(WECHSELN(X4;" ";WIEDERHOLEN(" ";599));SPALTE(A1:Z1)*599-598;599));)


Summe (ohne Hilfszellen, evtl. als SUMMENPRODUKT):
=SUMME(
WENNFEHLER(--GLÄTTEN(TEIL(WECHSELN(X4;" ";WIEDERHOLEN(" ";599));SPALTE(A1:Z1)*599-598;599));))


Quelle:
http://www.office-hilfe.com/support/showthread.php/22254-String-oder-csv-mit-Trennzeichen-per-Formel-auf-Zellen-aufteilen

Betrifft: AW: GLÄ-WEX-WDH
von: Patrick
Geschrieben am: 17.09.2020 14:41:31

Vielen Dank - wusste nicht mehr woher die Formel war, du hast mir da einen enormen Dienst erwiesen. :-)

Könntest du mir vielleicht noch erklären was genau die Formel macht? Der Teil "WIEDERHOLEN(" ";599));SPALTE(A1:Z1)*599-598;599" ist mir ehrlich gesagt unverständlich...

LG Patrick

Betrifft: Das steht im Link.
von: lupo1
Geschrieben am: 17.09.2020 14:57:58

Kurz gesagt: Ich erzeuge lange Leerketten, um die Inhalte grob, ohne Maß nehmen zu müssen, herauszuteilen. Anschließend verschwinden die Leerketten über GLÄTTEN.

Ab xl2013 funktioniert =XMLFILTERN() demgegenüber umfangreicher. Steht auch im Link.

Beides sind Krücken. Die Gemeinde wartet auf =SPLITTEN(). Ist noch nicht veröffentlicht.

Betrifft: AW: Werte aus Zelle in Spalten aufteilen
von: Günther
Geschrieben am: 17.09.2020 14:56:11

Moin,
in deiner Version ist das über Daten | Abrufen und transformieren nun wirklich kein Hindernislauf...
 
Gruß
Günther  |  mein Excel-Blog

Betrifft: AW: Werte aus Zelle in Spalten aufteilen
von: Daniel
Geschrieben am: 17.09.2020 15:31:12

Hi
wenn du nur die Summe brauchst und du trotz des VBA-Verbots die Dateitypen xlsm oder xlsb nutzen kannst, gäbe es noch folgende Lösungsmöglichkeit, welche die Summe direkt aus der Zelle ermittelt, ohne sie in Einzelwerte aufzuteilen:

1. markiere die Zelle, in welcher die Summe aus X4 stehen soll.
2. lege einen Namen, bspw "SummeNachbarZelle" an mit folgender Formel bei "bezieht sich auf":
=Auswerten(Wechseln(!x4;" ";"+"))
3. schreibe dann in diese Zelle die Formel =SummeNachbarZelle

die Formel kannst du dann in die anderen Zellen ziehen um weitere Zellen so auszuwerten.

das ist zwar nicht direkt VBA, aber es nutzt Methoden aus der alten Excel4-Makroprogrammierung, die Teilweise noch über NAMEN verwendet werden können, daher ist die Speicherung als xlsb oder xlsm erforderlich.

Gruß Daniel

Beiträge aus dem Excel-Forum zum Thema "Werte aus Zelle in Spalten aufteilen"