Microsoft Excel

Herbers Excel/VBA-Archiv

Formel "Links" für PLZ | Herbers Excel-Forum


Betrifft: Formel "Links" für PLZ von: Harald Haldenwang
Geschrieben am: 14.02.2012 11:12:00

Hallo zusammen,

versuche eine Liste zu erstellen, in der die Postleitzahl in einer Spalte und das PLZ-Gebiet stehen soll.

In etwa so:

A1= 01097 (Zelle als Sonderformat Postleitzahl)
B1= 01

Nun habe ich versucht dies mit der Formel "Links(A1;2) zu machen, aber leider gibt er mir die "0" nicht wieder. Vermutlich existiert die nur in der Sonderformatierung der Zelle. Sobald in der Postleitzahl statt der "0" eine richtige Zahl steht geht dies.

Habe mir einige Excellösungen versucht zu suchen, aber bisher ohne Erfolg.

Hat jemand eine Idee?

Danke und Gruß

Harald

  

Betrifft: Formatiere die Spalten als Text ... kwT von: Matthias L
Geschrieben am: 14.02.2012 11:13:50




  

Betrifft: AW: Formatiere die Spalten als Text ... kwT von: Harald Haldenwang
Geschrieben am: 14.02.2012 11:26:46

Nunja, die Liste existiert ja, und dann müsste ich alle Zellen durcharbeiten und die "0" hinzufügen. Dann kann ich auch gleich die Spalte mit der PLZ-Gebiet eintippen. Hatte die Hoffnung, dass kan man mit einer Formel lösen. Weil es sind nicht wenige Postleitzahlen, die mit "0" beginnen.

Gruß
Harald


  

Betrifft: AW: Formatiere die Spalten als Text ... kwT von: Dieter(Drummer)
Geschrieben am: 14.02.2012 11:41:40

Hi Harald,

evtl. hilft dir dies:

="0"&LINKS(A1;2)
Sonst habe ich keine weitere Idee.

Gruß
Dieter(Drummer)


  

Betrifft: AW: Formatiere die Spalten als Text ... kwT von: Harald Haldenwang
Geschrieben am: 14.02.2012 11:45:23

Danke sehr, hat geklappt.

für die PLZ die mit "0" beginnen mit deiner Idee, der Rest mit der Standard-Formel.

Gruß
Harald


  

Betrifft: AW: Danke für Rückmeldung,. kwT von: Dieter(Drummer)
Geschrieben am: 14.02.2012 11:50:30

.


  

Betrifft: :o) Gute Idee - mal angepasst von: Matthias L
Geschrieben am: 14.02.2012 11:46:47

Hallo zusammen

Tabelle1

 AB
1D-0107901
2D-6731167

Formeln der Tabelle
ZelleFormel
B1=WENN(LÄNGE(A1)=4;"0"&LINKS(A1;1);LINKS(A1;2))
B2=WENN(LÄNGE(A2)=4;"0"&LINKS(A2;1);LINKS(A2;2))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Matthias


  

Betrifft: AW: Formel "Links" für PLZ von: Dieter
Geschrieben am: 14.02.2012 11:54:30

Hallo Harald,

es geht auch mit =LINKS(TEXT(A1;"00000");2)

Gruß
Dieter


  

Betrifft: AW: Formel "Links" für PLZ von: BoskoBiati
Geschrieben am: 14.02.2012 15:14:35

Hallo,

warum eigentlich nicht so:

Arbeitsblatt mit dem Namen 'Tabelle3'
 AB
10106701
25120351

ZelleFormatWert
A1000001067
B1001
A20000051203
B20051

ZelleFormel
B1=KÜRZEN(A1/1000;)
B2=KÜRZEN(A2/1000;)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg



Gruß

Bosko


Beiträge aus den Excel-Beispielen zum Thema "Formel "Links" für PLZ"