Microsoft Excel

Herbers Excel/VBA-Archiv

Summe über alle vorherigen Zellen | Herbers Excel-Forum


Betrifft: Summe über alle vorherigen Zellen von: Grabner Franz
Geschrieben am: 16.01.2010 00:30:04

Hallo!

Ich hab mir gedacht ich lese die aktuelle Spalte aus und mache mir eine Summe von Anfangsspalte bis ausgelesene Spalte.

Nach langem googeln hab ich es geschafft die aktuelle Adresse der Zelle herauszubekommen
=WECHSELN(ADRESSE(29;SPALTE();4);;)
Ergebnis: B29

Wenn ich aber jetzt sage
=SUMME(B29:WECHSELN(ADRESSE(29;SPALTE();4);;))
dann geht es nicht. Die Funktion Auswerten() half mir auch nichts weiter.

Wie kann ich nun das Ergebnis einer Formel für eine andere Formel (als Adresse) verwenden?

Grüße
Franz

  

Betrifft: AW: Summe über alle vorherigen Zellen von: Hajo_Zi
Geschrieben am: 16.01.2010 06:46:42

Hallo Franz,

Indirekt. Ich würde vermuten so

=SUMME(Indirekt("B29:" & WECHSELN(ADRESSE(29;SPALTE();4);;)))

GrußformelHomepage


  

Betrifft: AW: Summe über alle vorherigen Zellen von: Grabner Franz
Geschrieben am: 16.01.2010 20:51:40

Ja, mit indirekt gehts! Danke für den Tip!

LG
Franz


  

Betrifft: Das, was du gemacht hast,... von: Luc:-?
Geschrieben am: 16.01.2010 09:04:13

...Franz,
kann man nur mit dem Ergebnis von Fktt machen, die vordergründig ein Range-Objekt zurückgeben wie bspw INDEX. Was du gemacht hast, ist also nicht völlig falsch, passt nur nicht zum Ergebnis von WECHSELN, denn das ist nämlich Text. Hier würde dann INDIREKT angeraten sein, wie auch Hajo es schreibt...
Gruß Luc :-?


  

Betrifft: oder mit BEREICH.VERSCHIEBEN von: Erich G.
Geschrieben am: 16.01.2010 10:12:35

Hi Franz,
mit BEREICH.VERSCHIEBEN kann das geschickter sein als mit INDIREKT. Probier mal:

 BCD
29230400
30  432
31  432
32  432

Formeln der Tabelle
ZelleFormel
D30=SUMME(INDIREKT("B29:" & WECHSELN(ADRESSE(29;SPALTE(); 4); ;)))
D31=SUMME(BEREICH.VERSCHIEBEN(B29;;;;SPALTE()-1))
D32=SUMME(BEREICH.VERSCHIEBEN(B29;;;;SPALTE()-SPALTE(B29)+1))

Rückmeldung wäre nett! - Grüße von Erich aus Kamp-Lintfort


  

Betrifft: AW: oder mit BEREICH.VERSCHIEBEN von: Grabner Franz
Geschrieben am: 16.01.2010 20:50:29

Hallo Erich!

Vielen Dank für deine Hilfe! Es funktionieren alle 3 Lösungen! Nur $B$29 sollte verwendet werden.

Echt super Unterstützung hier!

LG
Franz


Beiträge aus den Excel-Beispielen zum Thema "Summe über alle vorherigen Zellen"