Verlinkungsproblem Tabellenblattname in Excel 2003

Bild

Betrifft: Verlinkungsproblem Tabellenblattname in Excel 2003
von: Winfried
Geschrieben am: 30.11.2015 21:31:47

Guess Gott,
nach ein paar fruchtlosen Versuchen bitte ich die Experten mir zu helfen.
In einer Excel-Tabelle habe ich eine lange Formel, welche auf eine Datei im Netzwerk verweist. Wobei der Tabellen-Blattname nun von einer Zelle in der aktuellen Tabelle entnommen werden soll:
=[datei.xls]Tabelle1!$A$1
Der Tabellenblattname "Tabelle1" soll einer Zelle entnommen werden. Vereinfacht also:
=[datei.xls](Zelle_in_diesem_Tabellenblatt)!$A$1
Versuche mit INDIREKT und VERKETTEN sind gescheitert.
Über eine Lösung würde ich mich sehr freuen!
Winfried

Bild

Betrifft: AW: Verlinkungsproblem Tabellenblattname in Excel 2003
von: Matthias
Geschrieben am: 01.12.2015 00:10:19
Hallo Winfried,
probiers doch mal so:
=INDIREKT("[Datei.xls]"&B1&"!A1";1)
In B1 steht hierbei dein Name des Tabellenblattes, Bsp. "Tabelle1".
Indirekt und Verketten waren schonmal der Richtige Ansatz, das Verketten kann man aber auch durch "&"-Zeichen realisieren, kommt auf's gleiche raus.
lg Matthias

Bild

Betrifft: AW: Verlinkungsproblem Tabellenblattname in Excel 2003
von: Winfried
Geschrieben am: 01.12.2015 12:17:24
Vielen Dank Matthias!
die Formel ist so lang geworden:
=WENN(J27="";"";SVERWEIS(J27;'Z:\Eigene Datenquellen\[datei.xls]Tabellenblatt'!$A$4:$DA$2000; VERGLEICH("Spaltenbezeichnung";'Z:\Eigene Datenquellen\[datei.xls]Tabellenblatt'!$A$3:$DA$3;0);0))
Irgendwie hab ich den Überblick verloren: Sobald ich "Tabellenblatt" mit der Zelladresse "&B1&" (hier ist es K11) austausche und "INDIREKT" voranstelle, funktioniert es nicht mehr:
=SVERWEIS(J27;INDIREKT('Z:\Eigene Datenquellen\[datei.xls]"&K11&'!$A$4:$DA$2000; VERGLEICH("Spaltenbezeichnung";INDIREKT('Z:\Eigene Datenquellen\[datei.xls]"&K11&'!$A$3:$DA$3;0);0)); 1)
Nach dieser Eingabe fragt Excel im Dialog nach dem Tabellenblatt. Wählt man es aus, so korrigiert sich die Formel selbst und tauscht den Verweis &K11& mit dem Tabellenblattnamen aus. Danach erhalte ich die #BEZUG! Fehlermitteilung.
Meiner Meinung nach erkennt Excel den Zellverweis &K11& nicht als Verweis, sondern als Text, sonst käme nicht die Nachfrage "Arbeitsblatt K11 nicht gefunden in datei.xls Wählen Sie das Tabellenblatt aus..."
Über weitere Hilfe würde ich mich seeeehr freuen!
Mit freundlichen Dankesgruessen
Winfried

Bild

Betrifft: AW: Verlinkungsproblem Tabellenblattname in Excel 2003
von: Matthias
Geschrieben am: 01.12.2015 23:43:47
Hallo Winfried,
du hast auch einen Fehler gemacht. Verkettet werden Texte mit dem &-Zeichen. Texte werden immer in Anführungszeichen gestellt, sonst wird das ganze als Befehl interpretiert. Der Text ist in dem Fall Pfad+Dateiname und hinten 'ran noch die Zell-Adresse.
'Z:\Eigene Datenquellen\[datei.xls]Tabellenblatt'!$A$4:$DA$2000
Wichtig ist hierbei, dass du entsprechende Hochkommas und Ausrufezeichen nicht vergisst.
Nochmal zum Vergleich, dies hast du geschrieben:
INDIREKT('Z:\Eigene Datenquellen\[datei.xls]"&K11&'!$A$4:$DA$2000
So sollte es lauten:
INDIREKT( "'Z:\Eigene Datenquellen\[datei.xls]" & K11 & "'!$A$4:$DA$2000")
Dabei nicht die Klammer hintendrann vergessen. Die Leerzeichen habe ich nur eingefügt damit man die einzelnen Textstücken besser sieht, funktioniert aber genau so gut. Dies kannst du dann in deinen SVerweis kopieren.
Einen Haken hat Indirekt jedoch: Dies funktioniert nur solang wie die andere Datei ebenfalls geöffnet ist. Ansonsten wird dir nur "#Bezug!" angezeigt.
lg Matthias

Bild

Betrifft: AW: Verlinkungsproblem Tabellenblattname in Excel 2003
von: Winfried
Geschrieben am: 01.12.2015 15:16:48
Vielen Dank Matthias!
die Formel ist so lang geworden:
=WENN(J27="";"";SVERWEIS(J27;'Z:\Eigene Datenquellen\[datei.xls]Tabellenblatt'!$A$4:$DA$2000; VERGLEICH("Spaltenbezeichnung";'Z:\Eigene Datenquellen\[datei.xls]Tabellenblatt'!$A$3:$DA$3;0);0))
Irgendwie hab ich den Überblick verloren: Sobald ich "Tabellenblatt" mit der Zelladresse "&B1&" (hier ist es K11) austausche und "INDIREKT" voranstelle, funktioniert es nicht mehr:
=SVERWEIS(J27;INDIREKT('Z:\Eigene Datenquellen\[datei.xls]"&K11&'!$A$4:$DA$2000; VERGLEICH("Spaltenbezeichnung";INDIREKT('Z:\Eigene Datenquellen\[datei.xls]"&K11&'!$A$3:$DA$3;0);0)); 1)
Nach dieser Eingabe fragt Excel im Dialog nach dem Tabellenblatt. Wählt man es aus, so korrigiert sich die Formel selbst und tauscht den Verweis &K11& mit dem Tabellenblattnamen aus. Danach erhalte ich die #BEZUG! Fehlermitteilung.
Meiner Meinung nach erkennt Excel den Zellverweis &K11& nicht als Verweis, sondern als Text, sonst käme nicht die Nachfrage "Arbeitsblatt K11 nicht gefunden in datei.xls Wählen Sie das Tabellenblatt aus..."
Über weitere Hilfe würde ich mich seeeehr freuen!
Mit freundlichen Dankesgruessen
Winfried

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Verlinkungsproblem Tabellenblattname in Excel 2003"