Microsoft Excel

Herbers Excel/VBA-Archiv

VBA/Matrix Auswertung Stückliste

Betrifft: VBA/Matrix Auswertung Stückliste von: Phil69
Geschrieben am: 27.10.2020 15:50:34

Hallo zusammen,

wurde hier ins kalte Wasser geschmissen und versuche mich mit Excel.
Problemstellung:
Eine Excelmappe, mehrere Stücklisten eingefügt, mit über 3300 Zeilen ist gegeben.
Hier sollen nun alle Artikelnummern miteinander verglichen werden.
Soweit habe ich bereits eine Lösung zum Anzeigen der Häufigkeit der Artikelnummer (VBA).

Nun ist in einer weiteren Spalte die jeweilig verwendete Stückzahl angegeben.
Gesucht ist nun die Gesamtstückzahl der Artikelnummer.

So kann herausgelesen werden wie viele Teile dieses Artikels in den verschiedenen Baugruppen verwendet wird.

Das Forum ist mehr als interessant und ich hab schon einiges dazu gelernt, doch steh ich jetzt auf dem Schlauch.

Ich bedanke mich im Voraus!

https://www.herber.de/bbs/user/141129.xlsm

Grüße Phil

Betrifft: AW: VBA/Matrix Auswertung Stückliste
von: Herbert_Grom
Geschrieben am: 27.10.2020 17:08:11

Hallo Phil,

ich würde dir gerne helfen, doch sind deine Angaben sehr verwirrend! Vielleicht kannst du es ja noch einmal exakter beschreiben.

Soll die Auswertung über alle vorhandenen Sheets vorgenommen werden, oder nur jedes Sheet für sich?

Außerdem gehören Standard-Makros nicht in die "ClassModule", sprich in die Tabellen, sondern in Standard-Module!

Servus

Betrifft: AW: VBA/Matrix Auswertung Stückliste
von: Phil69
Geschrieben am: 28.10.2020 15:43:16

Ich danke euch für die super flinke Hilfe!

Als momentane Lösung habe ich die verschiedenen Tabellen zu einer zusammengefasst.
Diese habe ich dann mit dieser Matrix ausgearbeitet:

{=WENN(ZÄHLENWENN($C$4:C4;C4)=1;SUMMEWENN($C$4:$C$3215;C4;$F$4:$F$3215);"")}

So konnte ich mir die Mengen summiert anzeigen lassen.
(Leider nur neben der Tabelle auf Artikelzeile, habe mir dann aber die brauchbaren Daten in einer weiteren Tabelle zusammengefügt)

Mein Versuch mit einer Pivot Tabelle hat noch nichts brauchbares ergeben, da mir hier die Anzahl der Mengen anzeigen lassen konnte, jedoch nicht die Summe. Sobald "Summe" angewählt wird, wird hier nur 0 angegeben (Mengen wurden in Zahlenformat sowie in Standart getestet).

Das Fuchst mich noch etwas, werde mich nun aber selbst noch daran versuchen.

Ich bedanke mich für euren Hilfreichen Rat!

Grüße Phil

Betrifft: AW: VBA/Matrix Auswertung Stückliste
von: Yal
Geschrieben am: 27.10.2020 17:23:56

Hallo Phil,

ich glaube nicht, dass Du dein Glück mit VBA versuchen solltest.
Die gewünschte Kennzahlen können ganz einfach mit Pivottabelle zusammengefasst.

_ Bearbeite deine Tabelle, sodass "Artikel", "Beziechnung", usw anstatt von "Spalte3", "Spalte4" usw erscheint.
_ Füge eine zusätzliche Spalte für die Baugruppe anstatt diese als Überschrift (ja, es wiederholt sich: gehört aber so).
_ Reduziere die Anzahl von Tabellen auf nur eine

Pivot drauf. Artikel als Zeilenüberschrift, Anzahl von Menge und Summe von Menge als Kennzahl und schon hast Du es.

Viel Erfolg
Yal

Beiträge aus dem Excel-Forum zum Thema "VBA/Matrix Auswertung Stückliste"